Port forwarding being denied flags SYN on outside interface

I have Cisco ASA 8.4 pretty standard config. Inside and outside interface.  I have a bunch of ports forwarded and most are good.  I have port forwarding on a Windows 2000 server. (old yes, has some legacy programs on it).  I can get port 5900 for VNC to work, but I cannot get pcanywhere to work so I can remotely work on it. I get the following error: connection denied from x.x.x.x/1844 to x.x.x.x/5631 flags SYN on outside interface.
Couple lines from config:
object network newgenvnc
 host 192.168.1.16
object network newgenpcany
 host 192.168.1.16
object network newgenvnc
 nat (any,any) static x.x.x.x service tcp 5900 5900
object network newgenpcany
 nat (outside,inside) static x.x.x.x service tcp pcanywhere-data 5632

Any thoughts?
gbohrmanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Daniel SheppardSenior Network Analyst - Core & PerimeterCommented:
Are you doing any packet inspection?  It seems like it may be getting blocked by any packet inspection you may be doing.

What is your inbound IP access list like?
gbohrmanAuthor Commented:
This is issue started when we got a new range of IP addresses and I am putting in a new firewall. Cisco ASA 5505. The old one had version 8.2 this one has 8.4.  It works no problem to the old IP address and the 8.2 when I switch it back.  I've done as much side by side comparison is I can between the 2.

Here's my config:

ciscoasa# show run
: Saved
:
: Serial Number: JMX
: Hardware:   ASA5505, 512 MB RAM, CPU Geode 500 MHz
:
ASA Version 8.4(7)23
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xx.xx.67.74 255.255.255.248
!
boot system disk0:/asa847-23-k8.bin
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network local_192.168.1.0
 subnet 192.168.1.0 255.255.255.0
object network remote_192.168.3.0
 subnet 192.168.3.0 255.255.255.0
object network gentran
 host 192.168.1.15
access-list outside extended permit ip any any
access-list outside_cryptomap_3 extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static local_192.168.1.0 local_192.168.1.0 destination static remote_192.168.3.0 remote_192.
168.3.0 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network gentran
 nat (any,any) static xx.xx.67.76 service tcp pcanywhere-data 5632
access-group outside in interface outside
route outside 0.0.0.0 0.0.0.0 xx.xx.67.73 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 3 match address outside_cryptomap_3
crypto map outside_map 3 set pfs group1
crypto map outside_map 3 set peer xx.xx.67.130
crypto map outside_map 3 set ikev1 transform-set ESP-DES-MD5
crypto map outside_map interface outside
crypto ca server
 shutdown
 smtp from-address admin@ciscoasa.null
no crypto isakmp nat-traversal
crypto ikev1 enable outside
crypto ikev1 policy 1
 authentication pre-share
 encryption des
 hash md5
 group 1
 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet 192.168.3.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
tunnel-group xx.xx.67.130 type ipsec-l2l
tunnel-group xx.xx.67.130 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:379fccc03c69ab6001049f78d12fb952
: end
ciscoasa#
Daniel SheppardSenior Network Analyst - Core & PerimeterCommented:
Are you trying to use a range?  I just noticed this now, but your nat statement:

object network newgenpcany
 nat (outside,inside) static x.x.x.x service tcp pcanywhere-data 5632

Open in new window


would be incorrect if you are trying to use a range, it would be:

object network newgenpcany-1
 nat (outside,inside) static x.x.x.x service tcp pcanywhere-data pcanywhere-data
object network newgenpcany-2
 nat (outside,inside) static x.x.x.x service tcp 5632 5632

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gbohrmanAuthor Commented:
I'm still having an issue but I had a workaround for pcanywhere.  Now I am trying to FTP out to a customer. I connect and I'm able to login but I get the following error when trying to do anything:

501 IP Address for data destination doesn't match client's.
425 Can't build data connection: Addr family not supported by protocol

I'm not sure if my issue has to do with global NAT or something along those lines.  
I set up a computer with a connection straight to the internet with an ip address straight on the outside interface x.x.x.75 and gateway x.x.x.73 (basically bypassing the firewall) it works no problem.  But when I try from an inside host I get the error.  All inside addresses show as coming from x.x.x.74 which is the outside interface of the ASA.
gbohrmanAuthor Commented:
The range fixed my original issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.