• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1227
  • Last Modified:

Windows Small Business Server 2011 stopped sending daily Summary Network Reports

Our Windows Small Business Server 2011 stopped emailing daily Summary Network Reports.  When I go into the SBS 2011 Console > Reports tab,  and try to generate a report, it says generating for a long time and eventually the console crashes.
0
c_may
Asked:
c_may
  • 5
  • 4
  • 3
  • +1
2 Solutions
 
Randy DownsOWNERCommented:
Try this. It's a different scenario but may be relative.

1. Click Start>Run.

2. Type Services.msc

3. Look for "Windows Search" Service

4. Richt click on the "Windows Search" Service and click "Properties"

5. On the "Windows Search Properties" window under Startup Type choose "Automatic"

6. Click "Apply"

7. Then under Service Status, click on "Start" button

8. Click "OK"
0
 
Larry Struckmeyer MVPCommented:
Please look through this link and let us know if any help:

http://blogs.msmvps.com/bradley/2011/11/20/sbs-2011-monitoring-email-not-sending/
0
 
c_mayAuthor Commented:
Randy: Windows Search service in services.msc is already running and enabled.  I tried restarting the service with no success.

I should point out that not only will it not email, I cannot even generate a new report within the console without it crashing.  

Larry: from the link you provided I found this log file C:\Program Files\Windows Small Business Server\Logs\MonitoringServiceLogs\DataServiceComponents.log

In the log I found this error :

[20004] 150325.120125.7246: Messaging: MessagingTaskException: The operation couldn't be performed because object 'NT AUTHORITY\SYSTEM' couldn't be found on 'server.domain'. - Error# (80006)

I have tried to google this error.  I have found people asking about it but no solution.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Randy DownsOWNERCommented:
0
 
Larry Struckmeyer MVPCommented:
Hi:  

Researching your reply and have asked some others to chime in if they know a solution.  Meanwhile running the BPA can't hurt and may turn up something.
0
 
c_mayAuthor Commented:
3 updates for you all:

1.) I have run the SBS Console repair tool from control panel using the SBS 2011 DVD as suggested in another thread I found.  After restarting server, still cannot generate a report and consoles crashing.

2.) I also found this exception in same log file:  

An exception of type 'Type: System.Data.SqlClient.SqlException, System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' has occurred.
Timestamp: 03/24/2015 07:13:26
Message: Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.
Stack:    at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
         at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning()
         at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
         at System.Data.SqlClient.SqlDataReader.ConsumeMetaData()
         at System.Data.SqlClient.SqlDataReader.get_MetaData()
         at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
         at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
         at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
         at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)
         at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)
         at System.Data.SqlClient.SqlCommand.ExecuteReader()
         at Microsoft.WindowsServerSolutions.SystemHealth.Monitoring.MonitoringSQLDataStore.GetSecurityProducts(String computerName, String productNamespace, String className)

[2708] 150324.071626.7753: Exception:

3.) I have run BPA (updated to v. 1.5 w/ cab file)   It came up with some warnings. Results in screenshot below.

2015-03-25-1420.png
0
 
Randy DownsOWNERCommented:
Maybe something in this thread will help . There issue was crashing when network tab was clicked.

search the log file for

An item with the same key has already been added

or

b77a5c561934e089

If the entry exists you likely have orphaned WMI entries on client computers for Antivirus or Antispyware products and this is causing the console to crash.

Follow the steps in this article to resolve the issue.

http://blogs.technet.com/b/sbs/archive/2009/03/12/sbs-console-crashes-when-duplicate-entries-from-av-products-are-written-into-security-center.aspx 
0
 
Larry Struckmeyer MVPCommented:
Also, run the Fix My Network Wizard on the console.
0
 
c_mayAuthor Commented:
Did this search: An item with the same key has already been added
This wasn't in my log. Nor any other terms from that link (and my console doesn't crash when I click network tab).


When running Fix My Network Wizard, it does come up with these items below, but as I've said before, even when not trying to email, and simply generating a report crashes the console, so I'm wary to run this.  If any of these things look like they might be causing the crash on generating though let me know.

2015-03-25-1803.png
0
 
Larry Struckmeyer MVPCommented:
Appears you have a lot of remediation to do.  The only thing on the two lists you posted that you can ignore is the one about not being able to connect to the router.  You should expand the rest and take the suggested corrective action.  

Regarding the error for the reports, I am suspicious of the permissions on the default database and the lack of free space.  

In this folder:  

C:\Program Files\Microsoft SQL Server\MSSQL10_50.SBSMONITORING\MSSQL\DATA

what are the security permissions on the file sbsmonitoring.mdf?  Every file in that folder should show System - Full control
0
 
c_mayAuthor Commented:
Larry, I checked out the sbsmonitoring.mdf file and indeed system was not listed (Administrators group was).  I added it and gave full permission, but after a restart the reports still would not generate.

I did find a solution that worked, which involved recreated the SBSMonitoring database.  Instructions in link below:
http://blogs.technet.com/b/sbs/archive/2011/08/22/how-to-recreate-the-sbsmonitoring-database.aspx

I did have to force stop the SQL Server SBSMONITORING service as the script would create errors first because it wouldn't stop, so if anyone uses this, edit the file in the link and append '-force' after the stop services as the instructions suggest.

Thanks for helping everyone.
0
 
jollywhitefootCommented:
I see you have found a solution for your problem, but should the problem arise again, please make sure the Windows SBS Manager Service is running.
0
 
c_mayAuthor Commented:
Found own solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 5
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now