Vyatta firewall NAT hairpin issue

Hi Experts,

I am trying to setup NAT hairpin on Vyatta firewalls, but for some reason, it is not working as expected.

Traffic flow is as follows.
10.120.178.161 -> external IP on the same firewall on TCP 1414 -> 10.120.178.134

Sample config as follows.

Destination NAT
 rule 10
     destination {
         address "public IP"
         port 1414
     }
     inbound-interface bond1
     protocol tcp
     translation {
         address 10.120.178.134
     }
 }

Firewall Policy
 rule 15 {
     action accept
     destination {
         address 10.120.178.134
         port 1414
     }
     protocol tcp
 }

Source NAT
 rule 1 {
     destination {
         address 10.120.178.134
         port 1414
     }
     log enable
     outbound-interface bond0.1460
     protocol tcp
     source {
         address 10.120.178.161
     }
     translation {
         address masquerade
     }
 }

Please help. Thanks in advance.
jimmy1829Asked:
Who is Participating?
 
TimotiStDatacenter TechnicianCommented:
In local->local traffic, I think your DNAT rule won't match as the incoming is not bond1.

We did have similar issues with Linux hairpin NAT sometimes, in some cases the easiest method was to use simpleproxy on the firewall.

Tamas
0
 
jimmy1829Author Commented:
Exactly the case! We have figured out the issue to be that.
I ended up creating another DNAT rule
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.