Exchange Migration 2003 to 2010 New-moverequest Error

I am in the preliminary stages of moving mailboxes from my old 2003 server to my 2010 server.
I have moved 6 mailboxes successfully, but I just cam across a couple of mailboxes that return this message.

img1
I found something on Microsoft discussion board about giving the Exchange 2010 Server full rights using ESM.  
This did not work.  I am logged on as the Domain Administrator account.  I am wondering if I need to create a New account to manage the old and new server?
LVL 27
yo_beeDirector of Information TechnologyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kyodaiCommented:
Usually these are corrupted items in the mailbox, if you already moved several mailboxes then it's unlikely that there is any other issue.
VB ITSSpecialist ConsultantCommented:
Sounds like the mailboxes have bad/corrupted items that have exceeded the bad item limit you've set (20) which causes the mailbox move request to fail.

You can view a report of all these bad items by running this command: Get-MoveRequestStatistics –IncludeReport

I believe the highest you can set the -BadItemLimit switch to is 50 before the move request automatically fails. In these scenarios you will need to use the -AcceptLargeDataLoss switch to override this.

What most people don't know is that when a move request fails, the data is still there on the target side and the move request itself is still available to use. You can use these commands to continue the move request from where it has failed:
Get-MoveRequest 'John Doe'|Set-MoveRequest –BadItemLimit 100 -AcceptLargeDataLoss
Resume-MoveRequest 'John Doe'

Open in new window

This allows the move to pick up from where it has failed and saves you from having to wait for the initial seeding. If you'd prefer to start from a clean slate though then you'll have to remove the move request first before creating a new one.
yo_beeDirector of Information TechnologyAuthor Commented:
I just tried that additional switch and that did not resolve the issue.  Also I do not even see the user queued up in exchange 2010 for the move.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Seth SimmonsSr. Systems AdministratorCommented:
that is an information message because of the options you selected
considering you did -whatif, it didn't actually attempt to move the mailbox thus it wouldn't know if there are really any corrupted items

this question was answered previously

New-MoveRequest -WhatIf paramter
http://www.experts-exchange.com/Database/Software/Microsoft_Enterprise/Q_28006179.html#a38811690
yo_beeDirector of Information TechnologyAuthor Commented:
Here is what happens when I remove the WhatIf.

[PS] C:\Windows\system32>New-MoveRequest xxxxxx -TargetDatabase xxxMB01 -BadItemLimit 50 -AcceptLargeDataLoss -suspend
WARNING: When an item can't be read from the source database or it can't be written to the destination database, it
will be considered corrupted. By specifying a non-zero BadItemLimit, you are requesting that Exchange not copy such
items to the destination mailbox. At move completion, these corrupted items won't be available in the destination
mailbox.
Property expression "xxxxxxx" isn't valid. Valid values are: Strings that includes '@', where '@' cannot be the last cha
racter
    + CategoryInfo          : NotSpecified: (0:Int32) [New-MoveRequest], DataValidationException
    + FullyQualifiedErrorId : D836D6F8,Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest
Seth SimmonsSr. Systems AdministratorCommented:
ok, that is something different
you posted one command but you are talking about something else
seems you are missing -Identity in your command
yo_beeDirector of Information TechnologyAuthor Commented:
Found the issue:

The account did not have the Username Domain portion filling in.
I change the drop-down to have this field reflect the post Windows 2000 domain name.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hello WorldCommented:
Hi,

I want to double confirm whether all mailbox remove or special account cannot move to Exchange 2013?

If it's some special account, please try to max message limit in Exchange 2013. For your reference:
https://technet.microsoft.com/en-us/library/bb124345.aspx
Besides, you can add "LargeItemLimit" with a reasonable value (we recommend 10 or lower).
yo_beeDirector of Information TechnologyAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 500 points for VB ITS's comment #a40687050
Assisted answer: 0 points for yo_bee's comment #a40687135

for the following reason:

Thank you all for your help, but the cause to the issue was that the UserPrincipalName was missing the Domain name value. Once changed in AD then it worked.  I awarded points to VB ITS for pointing out the additional switches and options I have in Powershell.

Thanks once again.
Seth SimmonsSr. Systems AdministratorCommented:
your comment should be the accepted solution since you figured it out yourself, not the expert comment that made no reference to the missing UPN
yo_beeDirector of Information TechnologyAuthor Commented:
Ok,
If VB ITS has not objection to the request I will have the points revoked.
VB ITSSpecialist ConsultantCommented:
Agreed with Seth. Whilst you can opt to give points for assisting, your comment should be the accepted solution.
yo_beeDirector of Information TechnologyAuthor Commented:
Ok.
I will request to have the point removed.
yo_beeDirector of Information TechnologyAuthor Commented:
I ended up looking at the user's properties in AD and saw that he did not have a domain name associated with his account.
Once selected this resolved it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.