Mysql installation problem

Can we install MySQL 5.6.12 and MySQL 5.6.10 install in the same system ? How can I fix this problem? At least MySQL should display warning or should not allow me?
LVL 36
Loganathan NatarajanLAMP DeveloperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

skijCommented:
Loganathan NatarajanLAMP DeveloperAuthor Commented:
I read already this. what happens if I install at time the same version of mysql?
skijCommented:
It should work.  Follow the instructions and if you run into any specific problems, post the specific problems as a new question.  Thanks.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

jimyXCommented:
> Can we install MySQL 5.6.12 and MySQL 5.6.10 install in the same system ?

Yes, you can.

How can I fix this problem?

What problem?

At least MySQL should display warning or should not allow me?
If you are using the installer and on windows, then the port and the service name will be blocked and you will not be able to use them (unless you changed the default or you do not run MySQL as a service).

But there should be no problem having two versions, as long as they are not sharing the same data directory.
Loganathan NatarajanLAMP DeveloperAuthor Commented:
But there should be no problem having two versions, as long as they are not sharing the same data directory.


I am installing the same versions ->  5.6.12 vs 5.6.10   ...   5.6. x ->  12 & 10 making different.. so when I install mysql does not show any message...

because it assumes 5.6.x ? on same folder? it overwrites?

Please advise now?
jimyXCommented:
> because it assumes 5.6.x ? on same folder? it overwrites?
If you did not change the destination folder, of course it overwrites.
You need to be aware that there is previous version before proceeding. And while installing you select custom and change the installation path.
That has changed, IIRC, at version 5.6.14, when installing over 5.6.12, it will ask if you need to upgrade.
But even with later versions, if you install 5.6.14, for instance, over 5.6.10 it will not ask. As it does not realize it.

I am installing the same versions ->  5.6.12 vs 5.6.10   ...   5.6. x ->  12 & 10 making different.. so when I install mysql does not show any message...

This has been implemented in the later versions (~5.6.14).

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.