• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 92
  • Last Modified:

Regsvr32.exe not able to register any dll files

When trying to install an upgrade to my redline software i was greeted with an error and called the companies support to get it fixed. upon further inspection, the failed upgrade install has somehow blocked my ability to register dll files via regsvr32.exe.

I get the following error whenever i try to register ANY dll file:
The module c:\(pathname of dll)" may not compatible with the version of windows that you're running. Check if the module is compatible with an x86 or x64 version of regsvr32.exe

Tried some searching on google with no fix found. Maybe i wasn't searching the correct syntax. Hopefully someone here can help me out.
0
JJones312
Asked:
JJones312
1 Solution
 
TeargasCommented:
hello,

did you try to use the systemfilescanner from windows?

just run sfc /scannow with elevated rights in the command prompt.

http://support.microsoft.com/en-us/kb/929833
0
 
JJones312Author Commented:
That worked! Thanks for the suggestion.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now