Citrix xenapp 6.5 Discovery Fails after moving servers between Data Centers

Hi

I have a simple Citrix Xenapp 6.5 setup - one vm web server, one vm SQL server, and two physical app servers.  After migrating the entire package from one data center to another, I can't get a successful discovery in AppCenter.  Nothing shows up under citrix Resources\XenApp.

I can rdp to all servers, can ping between them, and DNS is working.

I thought that at first it was because all the sql services were stopped, but I got them all running and rebooted everything in the farm and still no discovery.

The web interface is up and I can log in with no problems and can even open a couple of the apps that are running on the app servers.

The web on sql servers were migrated and online for about a month before the app servers because of physically shipping them across the country.

Not sure where to go from here.  Any help is appreciated.  Thanks!

Tony
tonyjoewalkerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Matt VCommented:
Did you change the IPs when you moved them?
0
tonyjoewalkerAuthor Commented:
yes, all the IP addresses had to change.  Is there something I need to update in the app center?
0
Matt VCommented:
Yes, stop the IMA service on each machine (1 at a time is fine) and then run

dsmaint recreatelhc

Then start the IMA service again.  

Servers should start showing up.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Sekar ChinnakannuStaff EngineerCommented:
hope you followed above steps

Changing citrix servers IP address no issues, but make sure you have configured the WI server and other servers settings with server name not with IP address.

To Change IP for a citrix server
- Stop the IMA service & set to manual
- Change the IP Address
- Reboot the server
- Verify that other servers and clients able to ping
- Restart the IMA service and then set the IMA Service to automatic

You have to add new IP in web interface if you are using IP.
0
tonyjoewalkerAuthor Commented:
Hi

I stopped the IMA, ran the dsmaint recreatelhc on the web server and one of the app servers.  The IMA service would not start, so I rebooted everything.  IMA service still would not start so I rebooted the SQL server.  Still won't start.  Attached are the error messages.  

The last one is the most telling.  Not sure how to check the creds it's using as its been a long time since I had to administer this.  Thanks!

Tony
citrixErrors.docx
0
Matt VCommented:
Did you configure the SQL server connection as IP or hostname?

Check that the correct settings are in C:\Program Files (x86)\Citrix\Independent Management Architecture\mf20.dsn

[ODBC]
DRIVER=SQL Server
DATABASE=citrix_ds
APP=Citrix IMA
UID=citrixuser
SERVER=SQLSERVER\SQLINSTANCE

Also verify that the account the IMA service is running as is not locked out.
0
tonyjoewalkerAuthor Commented:
Hi

the dsn is configured with hostname and ping returns the correct IP.  the current dsn file has the correct server and database name.  My dsn shows

Server=servername

should I change it to server=servername\sqlinstance?  The database= line is the correct db name.

I used notepad to edit mf20.dsn to change server=servername to server=servername\sqlinstance but got the same error as in the attachment.

The service account is a local admin and a SQL sysadmin.  I tried using my domain admin account with the dsmaint config to change the user name and password and it didn't connect either.

I've been trying to run dsmaint config  /user:username /pwd:password /dsn:dsnfilename as in the attachment but it won't take.  

using lockout.exe is seems every time I run the dsmaint config the bad password count goes up one.  I copied and pasted the password out of the cmd window and changed the password again in AD.  So I created a new SA and am running the sql services under that account but still won't connect with dsmaint config...

sorry if this is kind of rambling...
citrixerror2.png
0
tonyjoewalkerAuthor Commented:
so close.  the solution was to use the full path for the dsn file location:

dsmaint config /user:domain\username /pwd:password /dsn:"C:\Program Files (x86)\Citrix\Independent Management Architecture\mf20.dsn"

Thank you for your help.
0
tonyjoewalkerAuthor Commented:
Thank you!
0
Matt VCommented:
Sweet, glad you got it working!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.