Cisco MDS Running Config question

I have this running config from a cisco mds 9124 we have at work in our test environment

I just want someone to break down what is on it. As far as I am aware a VSAN is essentially the same as a VLAN, when it comes to mds fibre switches?

What are the rule commands at the start?

Is everything just in the same (defualt) VSAN?

If anyone could highlight and break down exactly what's going on, on this mds switch, I would be grateful!

It's just for my own knowledge really and it looks like a simple config

Cheers


QS-4GbSwitch-A# show run
!Command: show running-config
!Time: Tue Jan 20 02:15:46 2015
version 5.0(1a)
feature telnet
role name default-role
description This is a system defined role and applies to all users.
rule 5 permit show feature environment
rule 4 permit show feature hardware
rule 3 permit show feature module
rule 2 permit show feature snmp
rule 1 permit show feature system
username admin password 5 $1$dmk0q6Gd$GdOvMRBm6Yphe4cO0CVFN/ role network-admin
no password strength-check
ip domain-lookup
ip host QS-4GbSwitch-A 172.110.2.191
ip host QS-4GbSwitch-A 172.110.2.191
aaa group server radius radius
snmp-server user admin network-admin auth md5 0x1e6cef2495148ba5c04a87df3e7b9e91
localizedkey
snmp-server host 172.110.2.201 traps version 2c public udp-port 1163
[7m--More--[m
fcdomain fcid database
[7m--More--[m
vsan 1 wwn 20:01:54:7f:ee:e8:24:80 fcid 0x620c00 area dynamic
vsan 1 wwn 50:01:43:80:03:b0:37:00 fcid 0x620d00 dynamic
vsan 1 wwn 50:01:10:a0:00:18:1f:b8 fcid 0x620e00 dynamic
vsan 1 wwn 50:06:0b:00:00:64:07:60 fcid 0x620f00 dynamic
vsan 1 wwn 50:01:10:a0:00:17:b1:b8 fcid 0x621000 dynamic
vsan 1 wwn 50:01:43:80:06:36:29:04 fcid 0x621100 dynamic
vsan 1 wwn 50:01:43:80:06:36:2e:84 fcid 0x621200 dynamic
vsan 1 wwn 20:26:00:a0:b8:42:22:66 fcid 0x621300 dynamic
vsan 1 wwn 50:01:43:80:03:b0:ae:54 fcid 0x621400 dynamic
vsan 1 wwn 50:01:43:80:03:b0:ad:c4 fcid 0x621500 dynamic
vsan 1 wwn 20:06:00:a0:b8:26:cb:7f fcid 0x621600 dynamic
vsan 1 wwn 20:06:00:a0:b8:26:cb:80 fcid 0x621700 dynamic
vsan 1 wwn 50:01:43:80:06:36:27:a2 fcid 0x621800 dynamic
vsan 1 wwn 50:01:43:80:06:36:25:16 fcid 0x621900 dynamic
vsan 1 wwn 50:01:43:80:03:b0:ae:0d fcid 0x621a00 dynamic
vsan 1 wwn 20:16:00:a0:b8:42:22:66 fcid 0x620000 dynamic
vsan 1 wwn 50:01:43:80:00:ac:d8:5a fcid 0x620100 dynamic
vsan 1 wwn 50:01:43:80:06:36:e1:ec fcid 0x620200 dynamic
vsan 1 wwn 50:01:43:80:06:35:93:78 fcid 0x620300 dynamic
vsan 1 wwn 50:03:08:c0:98:01:00:05 fcid 0x620400 dynamic
vsan 1 wwn 50:03:08:c0:98:01:00:01 fcid 0x620500 dynamic
vsan 1 wwn 50:03:08:c0:98:01:00:95 fcid 0x620600 dynamic
[7m--More--[m
vsan 1 wwn 50:03:08:c0:98:01:00:99 fcid 0x620700 dynamic
vsan 1 wwn 50:03:08:c0:98:01:00:9d fcid 0x620800 dynamic
vsan 1 wwn 50:03:08:c0:98:01:00:91 fcid 0x620900 dynamic
vsan 1 wwn 50:01:43:80:06:34:b9:40 fcid 0x620a00 dynamic
vsan 1 wwn 21:00:00:1b:32:83:80:b2 fcid 0x620b00 dynamic
ip default-gateway 172.110.1.254
switchname QS-4GbSwitch-A
line console
boot kickstart bootflash:/m9100-s2ek9-kickstart-mz.5.0.1a.bin
boot system bootflash:/m9100-s2ek9-mz.5.0.1a.bin
interface fc1/1
interface fc1/2
interface fc1/3
interface fc1/4
interface fc1/5
interface fc1/6
interface fc1/7
interface fc1/8
interface fc1/9
interface fc1/10
interface fc1/11
interface fc1/12
[7m--More--[m
interface fc1/13
interface fc1/14
interface fc1/15
interface fc1/16
interface fc1/17
interface fc1/18
interface fc1/19
interface fc1/20
interface fc1/21
interface fc1/22
interface fc1/23
interface fc1/24
system default zone distribute full
!Full Zone Database Section for vsan 1
zone name zone1 vsan 1
member interface fc1/1 swwn 20:00:54:7f:ee:e8:24:80
member interface fc1/2 swwn 20:00:54:7f:ee:e8:24:80
member interface fc1/3 swwn 20:00:54:7f:ee:e8:24:80
member interface fc1/4 swwn 20:00:54:7f:ee:e8:24:80
member interface fc1/5 swwn 20:00:54:7f:ee:e8:24:80
member interface fc1/6 swwn 20:00:54:7f:ee:e8:24:80
member interface fc1/7 swwn 20:00:54:7f:ee:e8:24:80
[7m--More--[m
member interface fc1/8 swwn 20:00:54:7f:ee:e8:24:80
zoneset name zoneset1 vsan 1
member zone1
zoneset activate name zoneset1 vsan 1
interface fc1/1
port-license acquire
interface fc1/2
port-license acquire
no shutdown
interface fc1/3
port-license acquire
no shutdown
interface fc1/4
port-license acquire
no shutdown
[7m--More--[m
interface fc1/5
port-license acquire
no shutdown
interface fc1/6
port-license acquire
no shutdown
interface fc1/7
port-license acquire
interface fc1/8
port-license acquire
no shutdown
interface fc1/9
no shutdown
interface fc1/10
no shutdown
interface fc1/11
[7m--More--[m
no shutdown
interface fc1/12
no shutdown
interface fc1/13
no shutdown
interface fc1/14
no shutdown
interface fc1/15
no shutdown
interface fc1/16
no shutdown
interface fc1/17
no shutdown
interface fc1/18
no shutdown
[7m--More--[m
[K
interface fc1/19
no shutdown
interface fc1/20
no shutdown
interface fc1/21
interface fc1/22
no shutdown
interface fc1/23
no shutdown
interface fc1/24
no shutdown
interface mgmt0
ip address 172.110.2.191 255.255.0.0
switchport speed 100
no system default switchport shutdown
[7m--More--[m
[K
QS-4GbSwitch-A#
LVL 2
piedthepiperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

asavenerCommented:
You are correct about VSANS.  They logically separate devices.

http://www.cisco.com/en/US/products/ps5989/products_configuration_guide_chapter09186a0080662ce3.html

role name default-role
description This is a system defined role and applies to all users.
rule 5 permit show feature environment
rule 4 permit show feature hardware
rule 3 permit show feature module
rule 2 permit show feature snmp
rule 1 permit show feature system
These rules are role-based access permissions, that are applied to the role named at the top.

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/mds9000/sw/4_1/configuration/guides/cli_4_1/clibook/clicfgur.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
piedthepiperAuthor Commented:
I know on a normal cisco switch you do
int range gi1/0/1-10
switch access vlan 11
this puts ports 1-10 into vlan 11
If the vlan doesn't exist it is created there and then

I am having trouble seeing how this is done with the VSAN in this config?
0
piedthepiperAuthor Commented:
I've tried but the images that are part of it, don't load Cisco website sates 404 not found! haha
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.