Link to home
Create AccountLog in
Avatar of James Atherton
James AthertonFlag for United States of America

asked on

office crashing on windows 2012r2 via rdp on tablet devices

I have a windows 2012r2 server running RDS, when I connect from any windows 7/8/8.1 pc all is well, I connect from a tablet device, and office crashes on exit, word, excel, outlook, access, the works.  I am sure it has something to do with the pen/onscreen keyboard interfaces as there seems to be a correlation.  Please see below.  Again this only occurs on tablet devices.

I need to know how to fix this as I will have others joining the fold with tablet devices and this could be a huge annoyance.

Description:
  Stopped working

Problem signature:
  Problem Event Name:      APPCRASH
  Application Name:      WINWORD.EXE
  Application Version:      15.0.4701.1001
  Application Timestamp:      54e3144c
  Fault Module Name:      PenIMC.dll
  Fault Module Version:      3.0.6920.7903
  Fault Module Timestamp:      51ea2707
  Exception Code:      c0000005
  Exception Offset:      0000000000005d37
  OS Version:      6.3.9600.2.0.0.144.8
  Locale ID:      1033

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
Avatar of Lionel MM
Lionel MM
Flag of United States of America image

What are the details on the tablet, make, model, operating system? Does it connect to the server in the same way as the windows 7/8/8.1?
Avatar of James Atherton

ASKER

Two different tablet devices have been tested to date, it was discovered using a new Surface 3, windows 8.1 latest updates, tried Remote desktop manager 2.7, inherent Windows Remote Desktop, and the RDP app from the app store.  When it was discovered I tried the same gambit using my Samsung 700t tablet device also using windows 8.1.  We have no tablet devices using anything under 8.1 at this time.
Can you go to device manager and uninstall the pen driver and then re-test to see fi that is the root cause? And you say you did go to device manager and right click on the pen driver and try to get the latest update, right?
ASKER CERTIFIED SOLUTION
Avatar of Brian B
Brian B
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I will double check the safe mode test, I think I tried that but do not remember.  I will also try uninstalling the pen driver and let you know, this won't happen till tomorrow afternoon so please bare with me...
So you know, I was able to test safe mode and it appears not to crash, I have not tried uninstalling the pen driver as of yet. Just wanted to let you know about the safe mode in case that helps.
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Just to clarify what I said, when others had the issue the pen driver itself was not the problem, but was conflicting with another driver. So uninstalling the pen driver might just move the problem to another driver.

However since this is a server, the pen driver probably has little or no use anyway. So best to try that first.
Agreed--and I was not disagreeing with you but jatherton said that is what he suspected so there is nothing wrong with him trying out what he suspected as the problem--if it is not we know for sure.
I have a question, the pen driver I assume is the one on the tablet device, as there is no pen device found on the server.  Although I am willing to try this on my tablet as soon as I can, if that is indeed the issue, there has to be a work around as I cannot expect everyone who has a tablet to uninstall the pen driver and in turn be unable to use their pen.

I will be trying this over the weekend when I have access to my tablet again, but the question still stands...
I removed the Dymo printer add-in, and boom, all better.  It dawned on me when we discussed the item relating to safe mode.  Thank you Gentlemen...

I think Dymo is out just to break everything...

Thanks again for all the help...
You're welcome and to answer you question about a work around removing stuff helps ID what the issue is and once we have then we can work to find a solution like in this case with the Dymo printer -- make sure you have the latest drivers and that the drivers are for OS that is crashing -- in most cases that resolves it.
Glad to help. I will add that one case of your error I found on the 'net specifically mentioned the Dymo driver being the problem as well.