We help IT Professionals succeed at work.
Get Started

Improve syntax in code block

AndyC1000 asked
Last Modified: 2015-04-12
Dear all,

I'm looking to make my program code more concise is there a better way to write the below code block?


if (((hour == hours) && (min == mins))) {

					if (!weekday) {
						value = s.getWeekend();
					} else {
						if (scenarioNumber == 1) {
							value = s.getScenario1();
						} else if (scenarioNumber == 2) {
							value = s.getScenario2();
						} else if (scenarioNumber == 3) {
							value = s.getScenario3();
						} else if (scenarioNumber == 4) {
							value = s.getScenario4();
						} else if (scenarioNumber == 5) {
							value = s.getScenario5();

Open in new window

Watch Question
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE