WSUS Fails to launch post installation tasks

Hi,

I have a server 2012 essentials box. WSUS was installed from the Roles and Features within server manager. However, after installation, this happens when trying to launch the post installation tasks:

2015-03-26 11:17:46  Postinstall started
2015-03-26 11:17:46  Detected role services: Api, UI, WidDatabase, Services
2015-03-26 11:17:46  Start: LoadSettingsFromXml
2015-03-26 11:17:46  Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentLocal
2015-03-26 11:17:46  Value is true
2015-03-26 11:17:46  End: GetConfigValue
2015-03-26 11:17:46  Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentDirectory
2015-03-26 11:17:46  Config file did not contain a value "ContentDirectory"
2015-03-26 11:17:46  Microsoft.UpdateServices.Administration.CommandException: A required configuration value was not found in the system. This is usually caused by installing WSUS through PowerShell and not specifying a configuration file. Review the article Managing WSUS Using PowerShell at TechNet Library (http://go.microsoft.com/fwlink/?LinkId=235499) for more information on the recommended steps to perform WSUS installation using PowerShell.
   at Microsoft.UpdateServices.Administration.PostInstall.GetConfigValue(String filename, String item)
   at Microsoft.UpdateServices.Administration.PostInstall.LoadSettingsFromXml()
   at Microsoft.UpdateServices.Administration.PostInstall.Initalize(Parameters parameters)
   at Microsoft.UpdateServices.Administration.PostInstall.Execute(String[] arguments)
Fatal Error: A required configuration value was not found in the system. This is usually caused by installing WSUS through PowerShell and not specifying a configuration file. Review the article Managing WSUS Using PowerShell at TechNet Library (http://go.microsoft.com/fwlink/?LinkId=235499) for more information on the recommended steps to perform WSUS installation using PowerShell.
LVL 1
joshhoughAsked:
Who is Participating?
 
Seth SimmonsSr. Systems AdministratorCommented:
that's because you're in the add roles and features wizard
that is for only adding additional roles and features; anything already installed will look like that
you need to go to remove roles and features (as i mentioned earlier) in server manager
0
 
David Johnson, CD, MVPOwnerCommented:
from server manager remove wsus, reboot, reinstall wsus and fill in the configuration i.e. WSUS data location
0
 
joshhoughAuthor Commented:
Hi

I have tried removing WSUS but because it hasn't been configured, it can't be removed from server manager....
0
 
Seth SimmonsSr. Systems AdministratorCommented:
so when you go to remove roles and features and uncheck the box, it won't let you proceed?
0
 
joshhoughAuthor Commented:
Hi,

Thats correct - as per the attached screenshot i can not un-tick it and then uninstall.

Josh
WSUS-Uninstall.jpg
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.