Configuring Lag ports for multiple VLANS

Hello Experts,

    I am configuring two Dell Powerconnect 8132F switches to be used for two purposes; iSCSI traffic AND VM network traffic.

The two switches are in between 3 Hyper V hosts and a Powervault SAN.

The SAN has 4 NICs, two go to SW1, and 2 to SW2.

Each host has 4 NICS, NIC1 goes to iSCSI SW1, NIC2 to iSCSI SW2, NIC3 to VM network SW1, NIC 4 to VM network SW2.

I do not have a stacking cable so I need to LAG the two switches together. These are 24 port switches.

Ports 1-8 are to be used on VLAN 30 for iSCSI traffic,
Ports 9-16 are to be used on default VLAN 1 for VM traffic (Hyper V hosts will be connecting to this switch and these ports are the used to communicate with rest of network, while the VLAN 10 ports 1-8 are segregated to be used only for iSCSI traffic.
Ports 17-19 are to be used as uplink ports to the CORE switch, which passes traffic to rest of network so clients can communicate with VMs. I need to LAG these ports too on SW1 and SW2 to the CORE switch upstream, and lag those ports as well.
Ports 20-24 are to be used to LAG the two switches together to pass traffic for both VLANS, so in the event that one switch goes down, VM network AND iSCSI traffic still flows.

I need some help with my configurations before going live with this environment. Below is what I have. These configurations are taken and modified from the Dell Equalogic Rapid configuration guide. I am not sure if I have the port channel groups correct, and I am not sure if I need to assign the LAGs to a VLAN in order to pass both VMnetwork and iSCSI traffic. Also, I am not sure if I should enable flow control and DCB on all ports. Please review an let me know thoughts. Thanks in advance!

Proposed Switch Configs for Powerconnect 8132F switches

1. Type the following commands to clear the current switch configuration:

console>enable
console#clear config
console>enable
console#copy running-config startup-config
console#reload

2. HTTP and Telnet authentication

console#config
console(config)#line telnet
console(config-telnet)#login authentication default
console(config-telnet)#exit
console(config)#ip http authentication local
console(config)#username admin password yourpassword privilege 15
console(config)#enable password yourpassword

3. Configure the Management IP

ip default-gateway 10.0.10.1
ip route 0.0.0.0 0.0.0.0 10.0.10.1 253
interface vlan 1
ip address 10.0.10.3 (SW1) / 10.0.10.4 (SW2) 255.255.255.0
exit
console#configure
console(config)#vlan 30
console(config)#exit
console#vlan 30
console#name "iSCSI"
console#vlan association subnet 10.0.11.0 255.255.255.0
console#exit


4. Configure iSCSI switch ports

console(config)#interface range Tengigabitethernet 1/0/1-8
console(config-if)#mtu 9216
console(config-if)#spanning-tree portfast
console(config-if)#Description iSCSI Port
console(config-if)#exit
console(config)#no dcb enable
console(config)#

5. Configure VMnetwork switch ports

console(config)#interface range Tengigabitethernet 1/0/9-16
console(config-if)#spanning-tree portfast
console(config-if)#Description VM Network Port
console(config-if)#exit
console(config)#

6. Configure  LAG ports between SW1 and CORE SW for uplinks

console(config)#interface range Tengigabitethernet 1/0/17-19
console(config-if)#no spanning-tree portfast
console(config-if)#channel-group 3 mode active
console(config-if)#exit
console(config)#interface port-channel 3
console(config-if-Po3)#exit
console(config)#exit
console#

Configure  LAG ports between SW2 and CORE SW for uplinks
console(config)#interface range Tengigabitethernet 1/0/17-19
console(config-if)#no spanning-tree portfast
console(config-if)#channel-group 4 mode active
console(config-if)#exit
console(config)#interface port-channel 4
console(config-if-Po4)#exit
console(config)#exit
console#


 Configure  LAG ports on CORE SW for uplinks from SW1
console(config)#interface range Tengigabitethernet 1/0/1-3
console(config-if)#no spanning-tree portfast
console(config-if)#channel-group 3 mode active
console(config-if)#exit
console(config)#interface port-channel 3
console(config-if-Po3)#exit
console(config)#exit
console#

Configure  LAG ports on CORE SW for uplinks from SW2
console(config)#interface range Tengigabitethernet 1/0/4-7
console(config-if)#no spanning-tree portfast
console(config-if)#channel-group 4 mode active
console(config-if)#exit
console(config)#interface port-channel 4
console(config-if-Po4)#exit
console(config)#exit
console#



7. Configure LAG ports between SW1 and SW2 to pass both iSCSI and Vmnetwork traffic

console(config)#interface range Tengigabitethernet 1/0/21-24
console(config-if)#no spanning-tree portfast
console(config-if)#channel-group 2 mode active
console(config-if)#exit
console(config)#interface port-channel 2
console(config-if-Po2)#mtu 9216
console(config-if-Po2)#exit
console(config)#exit
console#
LVL 1
CCtechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rgormanCommented:
Well, I don't have a Dell switch in front of me so I can't say with complete certainty what the exact commands are but I believe you need to assign VLAN 30 to the switch ports for your iSCSI traffic.  On Cisco switches it would be...

switchport access vlan 30

on the LAG's though you would want them configured in TRUNK mode so you would want to do the following (this is the Cisco command but the Dell one should be fairly similar)...

switchport mode trunk

You will also want to make sure both VLAN 1 and VLAN 30 are tagged on that trunked LAG interface.

Sorry I can't give a more specific answer.  I would need to go back to one of my clients networks with the Dell switches to give you the exact commands on how I did it with them.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CCtechAuthor Commented:
Oops! Missed the access VLAN 30 on the iSCSI ports, I will add that for sure. Thanks!

For the LAGs, I will add 'switchport mode trunk'

But once this command is added, won't these ports pass all VLANs without any further commands? If not, what are proper commands for tagging VLAN 1 and 30 on the LAG interfaces?
0
Craig BeckCommented:
In Cisco talk it's...

interface port-channel2
switchport trunk allowed vlan 1,30

Open in new window

0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

CCtechAuthor Commented:
Perfect, thank you I will add these commands as well.

I would like to leave this open in hopes of maybe some additional input on these commands. These switches will be installed in a production environment during live production time, as it is a 24/7 operation. There are over 30 VMs relying on this, so I want to make sure I have configurations correct. I will be standing up a test environment first, but would still like to see if we get any more input.
0
CCtechAuthor Commented:
I did confirm these commands work on the Powerconnects as well (switchport access vlan, switchport mode trunk, switchport trunk allowed).

Also, I am wondering if we should be using storm-control?
0
Craig BeckCommented:
You don't need to add storm control to those ports, but as long as you set it to a realistic value it won't hurt.
0
CCtechAuthor Commented:
These comments helped me to configure switch properly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.