Windows Server 2012 with Xenapp 7.5 Internet Explorer won't run

We have recently setup new servers with Windows 2012 with Citrix Xenapp 7.5 (previously we had Windows 2008 R2 with Xenapp 6). Most of the applications have been setup and running without any issues. I seem to have an issue with Internet. Specifically Internet Explorer (NOT the IE APP, but iexplorer.exe). I have trying to get to the bottom of this but can't seem to find anything that will point me in the right direction. When a user logs on for the first time, IE works fine. By the second day, it no longer works. When they launch IE they get a blank white screen and then after a minute or so it closes. I installed Firefox in the meantime, but for some integrated Sites, they need to use IE. I though I was getting somewhere when I tried the following. I deleted the Registry Key HKCU\Software\Microsoft\Internet Explorer and relaunched IE to create the key and it started working again. My thought was to compare the Regkeys when it fails with the keys when it works. The only problem is that now even after I delete the keys, it still will not load. This happens to different users randomly. Really wish someone had any idea to help me find the problem. UAC is disabled for all users. No errors in Event Viewer.
swenger7Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony JohncockLead Technical ArchitectCommented:
Tried it in safe mode i.e. no addons?

For things like this I find Sysinternals' Process Monitor really useful - download from Microsoft (they bought them some time back) and run. Filter on iexplore.exe

Something else - does it happen for admin users? Does it happen on the server console? Does it happen via RDP as opposed to ICA (this will rule it out being a XenApp/Receiver issue).

Edit: It might also be worthwhile doing a Malware/AV scan with an alternative product to what's installed.
0
swenger7Author Commented:
I have been doing some research and it seems that the issue has to do with the fact that I have Folder Redirection Enabled on my policy. This seems to cause isssues because some applications will write here while others will write to the c:\users\username\appdata\roaming.
0
swenger7Author Commented:
Once I removed the Folder Redirection, this issue and other minor issues I had all went away
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tony JohncockLead Technical ArchitectCommented:
I am curious about one thing...was this down to redirecting %APPDATA%?

That is known to cause issues but I must admit I've never seen this specific one.

Glad you resolved it.
0
swenger7Author Commented:
Found the solution on other forums and posted it here for others to see
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.