IIS Configuration

Ok I am setting up a web server, this is the first one I have set up in about 7 years so I am a little rusty. I am running Windows Server 2012 and IIS 8.5 hosted with 1&1. I have gone into IIS, added a new site and set the IP address for the site to the dedicated IP address assigned to my hosting account. However when I attempt to access the domain through an external browser I am still being redirected to the "Default Web Site" that 1&1 has set up in IIS. I have looked at the bindings of the default site and it is set to use "All Unassigned" IP addresses but since I assigned the primary IP address to my new site I thought that would, by default, override the "All Unassigned" setting.

My question is how do I get my site to be primary in IIS? I know I am missing a step somewhere but I cannot figure out what I have overlooked. I would prefer not to delete the Default Web Site because it is there for a reason.
gactoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rgormanCommented:
Are you using a DNS name to access your site?  If you are, is the DNS name only resolving to the IP address you assigned to your new site?  If it is just the server name it may have two entries for both IP's and that could be causing the issue if it is resolving the wrong IP.

Also, have you made sure your site is actually started?  Even though it is created it may not have started so you could right click it and make sure it is started.

If it still isn't working, you can try and set a host header in the binding and see if that helps.
0
Cliff GaliherCommented:
I'd simply stop the default web site.  You can leave it stopped without deleting it.  The "it is there for a reason" is actually not a big deal.  Some applications (Exchange being notable) will install stuff there, but in a default non-hosted install, it does nothing.  It is a placeholder.  So unless 1&1 is going crazy and throwing a ton of stuff in there (which I doubt) it can safely be stopped (or even deleted, but why bother...just in case down the road you need it) and let your site take precedence.
0
gactoAuthor Commented:
rgorman - I am using DNS and it is resolving to the correct IP address. The domain is www. spivey.farm and the IP address is 74.208.202.5. I have stopped and started the service several times so I am certain now that it is running.

Cliff - I didn't mention it in my post but I did stop the Default Web Site earlier and I am still getting the same results. The web page that is displayed when I navigate to www.spivey.farm is the Parallels Plesk page that bound to the Default Web Site in IIS.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

David Johnson, CD, MVPOwnerCommented:
in your bindings for the new website.. you did create a new website and not added a virtual directory by righclicking sites and selecting add website.
you should have got this page
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gactoAuthor Commented:
David - I had everything in the site setup exactly as you indicated above except for "Host name:" in "Binding" was spivey.farm instead of www.spivey.farm. I changed that one setting and everything is working now. Thanks for the suggestion, this was really starting to get on my nerves. Now can you tell me why this caused the site to work? Why couldn't I access the site with "spivey.farm" as the "Host name:" when I was typing spivey.farm as the URL in my web browser?
0
David Johnson, CD, MVPOwnerCommented:
most browsers automatically add the http://www. prefix and the .com suffix
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.