Dual LAN and Dual WAN on SonicWALL NSA2600

Hi,

We currently have a Sonicwall NSA2600 with X1 set as WAN, and all LAN devices connected to X0 using it for inbound/outbound internet.

We have a separate business unit that needs to connect X2 to another WAN internet connection, we would like to set any LAN devices connected to X3 to only use X2 for inbound/outbound internet (not X1). So basically, one router, two separate LANS connected to two Separate WANS.

I have this up and configured, but no matter what I have tried, the X1 LAN connection is still sending the traffic for the X3 subnet.

Here is the route I added for this:

X3 Subnet      Any      Any      X2 Default Gateway      X3      50      14

Any help on this?
tvurtAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lruiz52Commented:
Check the link below,  should help you set up secondary wan port.

https://support.software.dell.com/kb/sw7781
tvurtAuthor Commented:
Thanks for the link but that is all complete. I need to force a 2nd LAN segment to use the 2nd WAN interface.
tvurtAuthor Commented:
Bump?
Price Your IT Services for Profit

Managed service contracts are great - when they're making you money. Yes, you’re getting paid monthly, but is it actually profitable? Learn to calculate your hourly overhead burden so you can master your IT services pricing strategy.

masnrockCommented:
You would just need to create the proper NAT and routing rules. So X3 -> X2 and vice versa would be two of your rules in Routing Policies.

Here's a link to help: http://networkengineering.stackexchange.com/questions/10536/sonicwall-two-wan-interfaces-and-two-lan-interface-on-tz100-routing-question
J SpoorTME / Network Security EvangelistCommented:
you need a policy based route,

X3 Subnet      Any      Any      X2 Default Gateway      X3      50      14


it should say interface X2, not interface X3 !

you are now trying to route it back out of the lan interface.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
masnrockCommented:
Answered
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.