Network Shares only accessible when 'everyone' has full control - Server 2012

I have created an Administrator account for myself on the Server 2012 box and shared a folder that I have given Administrators full access to. I get 'access denied' every time I try to map a drive to the share with those credentials. If I open the rights up to 'everyone', I can then map with no issues. Where is my happy medium here?
HbugProjectAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
Share Permissions should be set to Everyone Full Control and NTFS permissions should be set accordingly. Make sure that those permissions are set properly first. Also is the account you are using to access this share part of the same domain?

I say this because when you say that the Everyone Permission it works Everyone works if your on a domain or not. Are you using a local administrator account on a member machine rather than a domain admin account?

Have you also tired this with another account other than the administrator?

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NVITEnd-user supportCommented:
Are you talking about share permissions or ntfs security rights?
0
albatros99Commented:
Consider setting 'Authenticated Uers' (not everyone) for the share rights because Everyone truly means everyone. Also, please be aware that the default share permission only gives you read access so you'll see 'Access Denied' even if all the NTFS rights are in place.

Check if the 'Administrators' you picked is actually the right group. For example, if you create a local admin account and then give access rights to the Domain 'Administrators' group, you will not have access.
0
HbugProjectAuthor Commented:
That did the trick! I only have to modify these settings about once every seven years when the server gets replaced. I forget about share rights vs. NTFS rights. Editing the share rights to everyone and then moving to NTFS rights for adjusting access worked very well.

One last question:
On this Server 2012 machine, I have added my account to the Administrators group. I cannot map a drive to C$ on that server using that account - access denied. UAC is disabled on that Server and C is not shared but shouldn't an admin be able to map to that with the $ regardless, just like the good ol' days?

Thanks again!
0
HbugProjectAuthor Commented:
It was UAC being enabled that prevented the C$ mapping. It's all taken care of. Thanks again everyone for the information.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Management

From novice to tech pro — start learning today.