Visual Studio only works when connected to my office's network.

Visual Studio 2012 projects won't load unless I am connected to the office network.  I get the following error when trying to open the project at home:  (load failed) - it shows in the solution explorer.  

I am running VS as admin.  I'm new to VS and don't know what could be the issue.  The project is located on my local drive.

Any help on solving this issue so that I can work from home would be greatly appreciated.

I'm working on a Dell Latitude running Windows 7.

Thanks,
J
ferguson_jeraldAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Naitik GamitSoftware DeveloperCommented:
This is most likely due to the path of your project has changed or similar. For example, you've moved the project into another location.

Verify the original files are there on your machine. If you select the missing project, and open properties, it will show you where it thinks the file should be (under Project File and Project Folder).

You can right click and re-load I think, or, remove the project and re-add it to your solution
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ferguson_jeraldAuthor Commented:
Thanks for the help, but when I click on Properties I get the following error:

"Creation of the virtual directory http://local host:50731/ failed with the error: unable to access the IIS metabase. You do not have sufficient privileges to access IIS websites on your machine."

I am running VS as admin., but I still get this error.  

Thanks,
J
0
David Johnson, CD, MVPOwnerCommented:
do you have iis with iis 6 tools/scripting enabled on your local computer?
0
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

ferguson_jeraldAuthor Commented:
Yes
0
David Johnson, CD, MVPOwnerCommented:
are you explicitly right clicking on the visual studio icon and running as administratorcheck your title bar
0
sarabandeCommented:
I would assume that your local firewall (or antivirus) blocks port 50731 from being accessed. you may disable firewall and see whether that could solve the issue. if yes, activate the firewall again but change the port configuration accordingly.

Sara
0
ferguson_jeraldAuthor Commented:
David - yes I am explicitly right clicking and running as administrator.

Sara - I looked and the firewall was already disabled.

I just changed the settings to use the Visual Studio Development Server instead of IIS, and it works just fine now.  I'm not sure why I can't use IIS successfully, but this change has allowed me to work on my projects while disconnected from my office network.

Thank you for trying to help!
J
0
ferguson_jeraldAuthor Commented:
Please close.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.