Windows 7 Professional Client cannot access shared folder on Windows 2008 Server

We changed the computer name on a Windows 7 Professional client and now it cannot access a shared folder on a Windows 2008 server in a Windows SBS2003 domain environment. The SBS2003 is the domain controller and the 2008 server is an application server. The client can access shared folders on the SBS2003 server but not on the 2008 server. The error message received is;

 \\SHAREDFOLDERNAME is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Logon Failure: The target account name is incorrect.

I have already tried removing the client from the domain and adding it back and that did not resolve the problem. Also, when viewing the network from the client, the 2008 server is visible but not accessible. Likewise, when viewing the network from the 2008 server, the client is visible but not accessible.

Tech support for the application said the 2008 server is remembering the host name associated with the original MAC and we need to find a way to reset the hostname/MAC on the 2008 server but I don't know how to do that.

Help?
RBEdwardsJrAsked:
Who is Participating?
 
JohnBusiness Consultant (Owner)Commented:
On the problem computer, run TCP/IP Reset and DNS Flush.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

See if that helps.
0
 
arnoldCommented:
How did you change the name, using netdom?
Check whether there are stale sessions on the 2008 server. Computer management, shares, share sessions.

Has the server been rebooted?
0
 
NVITCommented:
The error is from an application?
Can client access share via Windows Explorer?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
KromptonCommented:
Try resetting the computer object on the 2003DC then re-add the computer to the domain again.

Krompton
0
 
RBEdwardsJrAuthor Commented:
Arnold, changed the computer name through Control Panel>System and Security>System - Computer name, domain and workgroup settings. The 2008 server shows no sessions and no open files.
0
 
RBEdwardsJrAuthor Commented:
NewVillageIT, the error is received when attempting to access the share through windows explorer. Trying to access the share in order to install the application.
0
 
RBEdwardsJrAuthor Commented:
Krompton, while the client was removed from the domain, I deleted it through server management on the SBS2003 DC  and also confirmed that it was no longer listed in active directory . I added it back to the domain using the wizard under Control Panel>System and Security>System - Network ID. So I think that would have already accomplished what you are suggesting, wouldn't it?
0
 
KromptonCommented:
Yes it would. Sorry.
0
 
JohnBusiness Consultant (Owner)Commented:
If you tried DNS Flush to no avail (just a suggestion), then make a backup of the user account on SBS2003, delete the account and make new user account.
0
 
arnoldCommented:
Is this an AD environment? The change might still use the old account under a different name.

In an AD the way to change the name deals with using netdom command line tool.

Which location within the AD is the system now in?
On the client,
 Run
Net use y: \\servername\sharename

What is the error ID?
0
 
Natty GregIn Theory (IT)Commented:
when you change the computer name did you put back this computer into its original OU under computers
Is this new rogue device is authorized to use the system resources

in a domain setup user and computer must be authorize to use system resources, if the user is authorized but not the device in which they used to access system resources then its a no go

also check your error logs it usually points you in the direction of the solution
0
 
JohnBusiness Consultant (Owner)Commented:
@RBEdwardsJr - Thanks and I was happy to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.