RemoteApp Disconnected - This computer can't connect to the remote computer.

I've been spending hours using google, etc., to try to figure this out myself, but I'm coming up blank.  Everything was working perfectly 2 days ago.  Since then, I replaced the Comcast supplied cable/modem/router with a Zoom which forced me to change all of my internal IP numbering.  I then "re-keyed" the SSL certificates that I use for the Remote Gateway and the Host Session and now I can't connect my RemoteApps (using .RDP files or RDWeb...).  I'm thinking that the problem must be in the Remote Gateway, since I don't even get to the login screen using RDWeb!?  Internally, from one of my workstations I get this error:
RemoteApp-Disconnected.jpg
Externally, from an outside network, the .RDP connection prompts for credentials, then responds with this error:
RemoteApp-Disconnected--2-.jpg
I'm guessing it must be something simple, but, as much as I really like the RemoteApp capability built into Windows, whenever ANYTHING changes, it always creates problems.
Jim KlocksinOwner, Data ArchitectsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sajid Shaik MSr. System AdminCommented:
telnet to the server from out side using 3389 port..

trace the server IP ...

all the best
0
David Johnson, CD, MVPOwnerCommented:
since you change ip addressing you will have to update the dns to reflect the new settings and also the .rdp files (should have used \\servername vice \\192.168.x.x.\
0
Natty GregIn Theory (IT)Commented:
Couple of things
are port needed for rdp open in the firewall
when you changed the modem I assume your ip address change, since it has a different mac-address
when you setup rdp, was it ip specific if so update the app to the new address or machine whatever you re remoting into.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Couple of followup comments.  First, I've taken the firewall out of the picture.  I did have to change my public IP address for my Gateway server (thanks for that suggestion...).  I'm using an alternate port (i.e. not using 3389) and this has worked fine for the past couple of years, so I'm convinced that this is not the issue.  I still can't even get the login screen to display using the RDWeb functionality, yet I can ping my Gateway domain address with no problem.  Something seems to be blocking access to the "https://www.mydomain.com/RDWeb/en-us" web page and until I can access thru RDWeb via my browser, obviously, I'm not going to be able to connect using my .RDP files.  I've been trying everything I can think of and some basic setup options from a 3-part RemoteApp install and setup article I've used in the past!?
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
OK, seems to be working and something WAS blocking the process.  I had to completely disable the "built-in" firewall on my new Zoom cable modem/router.  After the firewall settings were set to off, both the RDWeb and .RDP files started working.  I knew it was something simple...I just wish I had thought about these firewall settings before I started this question.  The modem is a little deceiving in that the firewall settings claimed to not be blocking any ports (the way I had it set up originally), but I actually had to turn it OFF completely to get things working again.
0
David Johnson, CD, MVPOwnerCommented:
too bad you don't appear to have a setting in the cable modem/router to set your server in its DMZ
0
Jim KlocksinOwner, Data ArchitectsAuthor Commented:
Gave the points for the tip to check my public IP address after the cable modem switch, and this turned out to be a part of the problem since my domain name was still pointing to my prior IP address.  If I hadn't made this change, then I would still be working on this!
0
Natty GregIn Theory (IT)Commented:
thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.