NETSH DHCP SERVER Access Denied

Windows 2003 R2 SP2 DC1
Windows 2003 R2 SP2 DC2

I had only one DHCP server running on DC1 we had a power outage and DC1 was out for a long time.
DC2 was up and running so I decided to add DHCP server on DC2.
My network is 10.2.8.0/22 so I have plenty of address that the scope will not overlay.
I copied all the reservations from DC1 to the DC2 DHCP setup.

Then I authorized the DHCP server and started the DHCP server

Got this event error

Event Type:      Warning
Event Source:      DhcpServer
Event Category:      None
Event ID:      1056
Date:            3/28/2015
Time:            8:33:25 PM
User:            N/A
Computer:      SERV012
Description:
The DHCP service has detected that it is running on a DC and has  no credentials configured for use with Dynamic DNS registrations  initiated by the DHCP service.   This is not a recommended security configuration.   Credentials for Dynamic DNS registrations may be configured using the command line "netsh dhcp server set dnscredentials" or via the  DHCP Administrative tool.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Then I tried this
netsh dhcp server set dnscredentials administrator mydomain password
access is denied

then
netsh dhcp server show dnscredentials
access is denied

netsh dhcp server show server
the current server is serv012 .............   this works

when I do the above on DC1 no problem it works

DC2 owns all the AD Roles

Any thoughts?

Thanks

Tom
LVL 23
Thomas GrassiSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
are you running from elevated command prompt?
0
Thomas GrassiSystems AdministratorAuthor Commented:
Seth

Yes I also do run from elevated command prompt.

Thanks for replying

any other thoughts?
0
Seth SimmonsSr. Systems AdministratorCommented:
have you tried through dhcp console?
right-click on the server and go to properties
click credentials on the advanced tab and put the credentials there
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
netsh
dhcp
server \\servername
help

there are option set that you can use to set including dns as listed in the error message
set dnsconfig
set dnscredentials

Though I am not sure why you are getting this prompt. Are you running the DHCP service with domain credentials, or is it running as local system?
Not sure why you are getting those.
0
Thomas GrassiSystems AdministratorAuthor Commented:
Guys

Thanks

Once I set the credentials from the Console and after AD updated I was able to do command line netsh dhcp commands from the server and from my windows 7 computer.

Thanks again for all the help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.