Exchange 2010 Out of Office not working externally

I cannot seem to figure out why my Exchange 2010 server won't send out of office requests to external emails.  I have checked Autodiscover by using https://testconnectivity.microsoft.com/ and it tests ok.  I have set allow external out of office in the organization hub transport, remote domains tab.  I have selected the 3rd option: Allow external out-of-office messages and legacy out-of-office messages (configured by using Outlook 2003 or earlier clients, or configured on Exchange 2003 mailboxes

However the emails are not going externally.  The only error I have been able to find thus far is when I run the Test-OutlookWebServices -ClientAccessServer server command, I get the following in the ouput:  

RunspaceId : e398167d-ff3d-4745-83ce-2edf3c36033e
Id         : 1104
Type       : Error
Message    : The certificate for the URL https://server.xxxxxxx.local/Autodiscover/Autodiscover.xml is incorrect.
              For SSL to work, the certificate needs to have a subject of server.xxxxxxx.local, but the subject t
             hat was found is mail.xxxxxxx.com. Consider correcting service discovery, or installing a correct SS
             L certificate.

Not sure if this is my problem?

Any ideas/help would be appreciated!
David BarmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeff BrownGlobal Helpdesk SupervisorCommented:
So out of office messages from your exchange clients are not going to external servers??

In outlook 2007+  they split out of office messages into 2 sections internal and external.  You must set external out of office messages separately from the internal ones.  There are two tabs the internal one is showed first and you must specifically click on the external one.  The messages can be completely different internal and external so be sure to type in the message exactly as you want it shown for external. I always just copy the internal one because i usually want them to be the same.
0
David BarmanAuthor Commented:
Yes, I have both internal and external messages enabled via owa.
0
David BarmanAuthor Commented:
Any other ideas of what is going on here?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Simon Butler (Sembee)ConsultantCommented:
You need to correct your URLs first.
If you have a trusted certificate on the server then you need to use the external host names internally.
http://semb.ee/hostnames2010

The next thing you should check is whether the OOTO message is being generated and then blocked. That isn't unusual. Use Message Tracking to see whether Exchange is sending the message out. If internal OOTO messages are working, then so should external.

Finally you could reset the OOTO message. Alas that also means cleaning all of the rules in the mailbox out.

outlook.exe /cleanrules

If you have legacy clients, legacy Blackberry BES clients etc then they can create an OOTO message which doesn't always work correctly with the modern dual message method of Exchange 2010.

Simon.
0
David BarmanAuthor Commented:
How can I confirm that the URLs are correct? Also, should both internal url and external be the same?
0
Simon Butler (Sembee)ConsultantCommented:
In most cases the internal and external URLs are the same. Use a split DNS system to ensure they resolve correctly. As for checking they are correct, that is something that only you will know about from a host names point of view. The web page I have linked to above provides instructions on what needs to be set where for most installations.

Simon.
0
David BarmanAuthor Commented:
Still not resolved
0
David BarmanAuthor Commented:
What do you mean by a split DNS system?
0
Simon Butler (Sembee)ConsultantCommented:
Split DNS - that is when the external name is used internally.
http://semb.ee/splitdns

Simon.
0
David BarmanAuthor Commented:
Dns seems fine. What else should I be looking at as a source of the problem?
0
Simon Butler (Sembee)ConsultantCommented:
To be clear - you are able to set the OOTO message?
Outlook behaves as if it has been set with the banner in Outlook 2010 telling you it has been set?

When you send an email, does the OOTO message appear in Message Tracking?

The main reason for external OOTO is a stuck rule, as I have outlined above, or something else blocking the message, like AV or antispam. If that was the case then it would show in message tracking.

Simon.
0
David BarmanAuthor Commented:
Problem solved.  It actually wasn't an issue with exchange.  The issue was the smtp email relay service I was using to send out email.  The relay service was blocking all messages with "blank senders".  Once I enabled that feature on their service, the out of office now works.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David BarmanAuthor Commented:
My comment was the ultimate solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.