SharePoint Foundation 2013 Search not working

Hi

Search has stopped working  on my SharePoint Foundation 2013 installation.
The message in the logs is "this item could not be crawled because the crawler could not connect to the repository".

It looks like an obvious message, except that the crawl account does have permission to access the database.

We have a front end SharePoint server and a backend SQL server.

Any suggestions as to why this should have stopped gratefully appreciated.

Kevan
LVL 1
cmiadminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohit NairSenior AssociateCommented:
The crawl account should atleast have read permissions on the site. Check whether the Search service is started in services on server.
cmiadminAuthor Commented:
Hi.
The Search service is started.  I just restarted to make sure everything was OK. The Crawl account has read permissions on the site.
Kevan
Mohit NairSenior AssociateCommented:
I am not sure if you have search service application in foundation 2013. Could you please check in application management > manage service application. If not there, click new and check if you can create service app.
cmiadminAuthor Commented:
Hi

I seem to have fixed this. Not sure whether it was restarting the search service or the fact that I got a new message about one of the sites being searched was not in the Alternative Access Settings.  I removed this site from the search rules and content sources and now my search is running and I can already find documents.

Thank you for your swift replies though.

Regards.

Kevan

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cmiadminAuthor Commented:
Because I figured it out from new error message generated after restarting the services.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.