Exchange 2013 - Mail getting stuck in Drafts Folder

We've installed a 2013 exchange server along side a 2007 sp3 server we're migrating away from. Everything was functioning fine last night. In the morning mail isn't flowing either direction. Mail from OWA stays in the drafts folder. To my knowledge nothing changed between 12am last night and this morning.
Any help would be greatly appreciated.
artemisitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hello WorldCommented:
Hi,

Is there any error message or NDR when message delivery? How about internal and external mail flow?
Please try run Microsoft Remote Connectivity to test Exchange server, also run Test-ServiceHealth to monitor Exchange server.
Besides, run Message tracking log and Protocol log to get more details about message stuck.
0
artemisitAuthor Commented:
There are no NDR messages.
The connectivity test passes fully.
When I Do a Test-Mailflow cmdlet, it shows TestMailflowResult *Failure*
Test-ServiceHealth shows no services that weren't running.
0
Will SzymkowskiSenior Solution ArchitectCommented:
First thing i would be checking is the logs on each of the mailbox database servers. Are you using DAG for your mailbox database configuration?

If you cannot send mail then it is definitely something with the database and/or backend Transport service.

Have you tried to reboot your Exchange servers as well?

Will.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

artemisitAuthor Commented:
We're not using DAG.
We've rebooted the server.
I suspect something in the connectors or transport service.
I've opened a ticket with Microsoft but haven't received a callback yet.
0
Will SzymkowskiSenior Solution ArchitectCommented:
Have you checked the logs yet? Also have you tried rebooting the server/s and/or restarting the services on the Exchange Servers?

Also, i am assuming that all of the mailboxes are experiencing this issue and it is not just related to few mailboxes?

Will.
0
artemisitAuthor Commented:
After having troubleshot the issue with Microsoft, it seems there was a failed windows update at some point durring the night and the background services were in the state of "inactive"
This is viewed by issuing the cmd-let  Get-ServerComponentState
All the services showed inactive.
The next command sets the services to an active state
Get-ServerComponentState “Server Name” | % { Set-ServerComponentState “Server Name” -Requester Functional -Component $_.Component -State Active }
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
artemisitAuthor Commented:
Microsoft was able to solve the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.