localhost not working Windows 2008

I have a Windows 2008 R2 VM with IP address
I have an ASP.net web application installed on it.

On the same machine (the VM) :
http://localhost/Web1/login.aspx - does not work - does not work

From another machine : - does not work

What is the problem (URLs not working on local machine) ?
How can I fix it ?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do you have a host header set in the bindings for the site? Do you have the binding set to listen on a specific IP or is it set to "all unassigned"?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dan McFaddenSystems EngineerCommented:
Are you getting any .NET errors or just no response from the server?

Is the firewall service enabled on the server in question?  Is HTTP(s) allowed thru?

vu3lmgAuthor Commented:
Have been sidelined on another issue. Will try your suggestions and update next week.
Sorry for the delay.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.