Wordpress frontpage not static

Hi

A client of mine has developed a Wordpress site and set a static frontpage

The theme used is called Displace

The desired frontpage seems correctly selected in the reading pane of the admin settings

yet when one loads the site's URL it isn't always this page that is displayed

Any ideas how to fix this ?

thanks

yann
Yann ShukorOwnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tom BeckCommented:
I could not reproduce the problem after downloading the Displace theme on a Wordpress test site. Need more information.
0
Yann ShukorOwnerAuthor Commented:
Thanks Tom

not sure what info to provide
the issue occurs randomnly
I have personnally experienced it during two of my browsing attemps
0
Tom BeckCommented:
On each occasion where you experience the problem, is the URL pointing directly to the root directory of the site? In other words, there are no queries ("?") or category names in the URL.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Peter HartCommented:
I've  seen this on some themes where the home page is built into the theme and not an actual page.
either disable the "home page" in the theme settings or set the home menu item to "/" by using a custom link in the menu settings
0
Yann ShukorOwnerAuthor Commented:
Thanks Chiltern, I will try that
0
Yann ShukorOwnerAuthor Commented:
I can't disable the homepage in the theme's settings,
I can however avoid selecting anything for static page, but then I get the last post displayed as homepage

I tried creating a custom menu link, as suggested, but that doesn't seem to work. When browsing if I click on Home nothing happens

I had noticed last week that the theme's static page was set to 'Contacts'
I therefore corrected and saved the correct setting
Today I discovered that the setting had reverted back to 'Contacts' again !

I have sent a query to the theme's developper

I'm also wondering whether this issue could be linked to the WP version: 3.8.5 - I will ask the client why they haven't upgraded yet

PS
I didn't mention that the site also has a translation module (Ceceppa Multilingua)
0
Peter HartCommented:
if you website is in the root then
for the Home page menu to choose the root and not the home  "page"
 go to appearance - menu -
click on "links" on the URL  remove the http:/  and simply put /
on the link text put "Home"
click Add to Menu and move it into place. and save the menu.

for the home page appearing on the home page  try just have an empty page?
0
Yann ShukorOwnerAuthor Commented:
Thanks Chiltern

I tried it again just to make sure that I had done it right, but the "/"  takes us nowhere
I suppose it could mean that the site isn't in the root.

Funnily enough , I went back into the Theme's customization page and this time
there was another page in the the static homepage field (not Home, and not contacts)
0
Yann ShukorOwnerAuthor Commented:
Well infact this behaviour was due to a bug present int he multilingual plugin Ceceppa Multilingua

The developper has provided a revised version on Github
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Yann ShukorOwnerAuthor Commented:
situation solved by developper
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.