We help IT Professionals succeed at work.

SONIC WALL SITE-SITE VPN having troubles.

I have three sites with SonicWall Tz 205 at HeadOffice with TZ205 at one office and TZ 105 in other. Topology is that 2 branch offices are connected to HO through SITE-SITE VPN.

Subnet Details are:

Head Office:
X1 : Connected to WAN
X0 : 10.11.12.0 / 24 (LAN SUBNET)
DHCP : ON
Single class is used i have total of just 50 devices inclusing phones so i decided to use single subnet for all offices.

Branch Office:
X1 : Connected to WAN
X0 : 10.10.10.0 / 24 (LAN SUBNET)
DHCP : Off

Branch Office:
X1 : Connected to WAN
X0 : 10.12.13.0 / 24 (LAN SUBNET)
DHCP : Off

I have established SITE-SITE VPN and its up. Remote offices are getting IP's over DHCP through VPN. I have place Avaya IP Office in HO and phones are discovering and obtaining ip through tunnel using DHCP. Issue are.

1. I am unable to ping any device over VPN.
2. Avaya phones are connecting but calls dicsconnects after 5 min. It is only in remote office over vpn.
3. No device expect avaya phone is getting IP through VPN.

Please guide. . .
Comment
Watch Question

Director, SD-WAN Solutions
Commented:
with sonicwalls it all comes down to the address object groups you used to make the vpns. If you need branch offices to talk to each other, you have to make address object groups for both other sites and use those for the vpn tunnels.

here are the basics:
http://www.experts-exchange.com/Software/System_Utilities/Remote_Access/VPN/Q_25107854.html
http://www.sonicwall.com/downloads/sonicos_standard_2.0_site_to_site_vpn.pdf
http://kb.guru-corner.com/admin/attachments/utm__vpn__implementing_hub_and_spoke_sitetosite_vpn_on_sonicos_enhanced.pdf
Aaron TomoskyDirector, SD-WAN Solutions

Commented:
author abandoned