Group Policy Mapped Drives Not Being Applied

Good morning!

The Setup:
I have a small virtual environment with drive maps being applied through GPO.  I'm having an issue where drives are not being mapped for a specific user on a specific server.  My domain controller is Windows Server 2008 R2.  The server where the problem behavior exists is Windows Server 2008 Enterprise edition ("web server").  The user is a member of the local Administrators group on the web server.  

The Symptoms:
The user logs in to other Windows Servers on the domain and the mapped drives policy is applied successfully
I log in (as Administrator) to the web server and mapped drive policy is applied
User logs into the web server and mapped drives are NOT applied
I don't see anything in the Event Logs (tried searching "mapped" and "group policy" but nothing revealing)

Any ideas where I can look?

TIA!
LVL 1
ttist25Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Hi.

Please clarify if you use the GPO preference section for your network drive assignment.
Or is it a logon script?
Then please check whether that GPo got applied:
As that user on the server, execute
gpresult /h %temp%\result.html

Open in new window

and look at the resultfile.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David Johnson, CD, MVPOwnerCommented:
when you say logs into a webserver are you referring to the remote desktop gateway? how are they logging into that machine? Is it also a domain controller?
try running the following 2 commands
repadmin /showrepl webserver.example.com
dcdiag /test:replications
ttist25Author Commented:
Thanks for the response McKnife.  Very cool command.  Thanks for that!

Drives are mapped using a group policy object "User Configuration\Preferences\WIndows Settings\Drive Maps".

Here are some pieces of information in the result.html:
Last Time Group Policy was processed: 3/31/2015 9:15:00 AM (when I logged in as the user)
Applied GPOs: Mapped Drives (my mapped drives policy)
Denied GPOs: <Long Hexadecimal String> Link location: <my domain> Reason Denied: Inaccessible

Is there anything else you need from results.html?

Thanks again for the help.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

David Johnson, CD, MVPOwnerCommented:
Denied GPOs: <Long Hexadecimal String> Link location: <my domain> Reason Denied: Inaccessible
probably a guid  use powershell
Get-GPO -GUID “{AD7E3746-7135-496B-A1F5-B5B11871F96F}” and it will return the name so you can go into group policy editor or look in your sysvol folder for it.
ttist25Author Commented:
Hello David,

Thanks for your response as well.  The user is logging in via Remote Desktop.  The entire environment is virtualized.  The web server is not a domain controller and is part of the local domain.

Knowing this, should I still run the commands you reference?  

Thanks again!
ttist25Author Commented:
Hi David,

I ran Get-GPO -GUID and the term is not recognized as the name of a cmdlet.  Tried it on both the DC and the web server.  

Any tips?
McKnifeCommented:
There's no reason to go for the denied GPO since the GPO in question ("mapped drives") is being applied. You should do that, but don't have to now.
Please try something:
-map it manually (I guess that works)
-create another GPO just for that user (and within, use another drive letter for the mapping)

Also make sure, that the drive letter is not (for some reason) already taken.
David Johnson, CD, MVPOwnerCommented:
still have to find the GPO that is causing problems
ttist25Author Commented:
Thanks for the feedback guys.  I never found the cause of the issue and because of other more pressing deadlines, I'm not going to be able to figure it out (I'm mapping the drives on that server with a script).  

I selected your answers because they provided me with new tools that I'm sure will prove helpful in the future.

Sorry we couldn't get to the bottom of it.  

Thanks!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.