• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 613
  • Last Modified:

How to restore Access Apps after Service Applications crashed.

Hey guys,


I have an issue were I was forced to rebuild the service applications for my SharePoint 2013 environment. As a result, I've spend quite some time attempting to restore our Web Applications. I have completed the majority of the restore and SharePoint is working well, except for a few custom Access Web Apps that were built previously. If I add a new Access App it is successful, however trying to access the old apps results in the error "Sorry, we couldn't load this app. We weren't able to load the app's home page." The ULS log is leading me to believe it is because the app is still looking for the all Access Service and Application pool because it errors with "Cannot find site lookup info for request Uri http://<server>:<Port>/<New app pool guid>/AccessService.svc."  I normally would restore the app from an app package and then the data however this particular app was developed on a server running SQL 2014 and the user couldn't produce an app package for some reason. (something else to look into after this). Long story short, I'm trying to see if there is a way to update the service call for the app to the new service applications, or if there is a way to restore the app from the database considering that database holds everything for the app.
0
CooperRiis
Asked:
CooperRiis
  • 2
1 Solution
 
CooperRiisAuthor Commented:
Ok, after more research, I've realized that the log continues with "AccessServicesDatabaseServerGroupCollection.GetDatabaseServer: Could not find a server matching reference id 'd94ad509-e5ac-4243-ba8f-9ac78a196f1e'. Returning null."

Previously I believed this was due to the fact that it was not able to find the service, however, when I use my Get-SPAccessServicesDatabaServer PS cmd, I am given the ServerReferenceID "dea59c3c-2ddd-48d6-ac01-a4ba6a7c7511"

The app is looking for the wrong database it seems but I can't be sure. As a test I created a new test app and then restored the old app's SQL database over the test apps SQL database. This resulted in the same error messages, so I'm thinking the value is stored somewhere in the SQL database.

Any ideas would be very helpful...
0
 
CooperRiisAuthor Commented:
I found what I was looking for and was able to get the services and all of my apps working again.




In case anyone else is having this problem, look in the AppDataMetadata and AppInstallationProperty tables of your Web Application content database on which the erring apps are installed. In the AppDatabaseMetadata table the referenceId should point to the Guid of your database server that can be found using the Get-SPAccessServiceDatabaseServer PS cmd. Mine was pointing to the old server Guid which was appearing in the error code "AccessServicesDatabaseServerGroupCollection.GetDatabaseServer: Could not find a server matching reference id 'd94ad509-e5ac-4243-ba8f-9ac78a196f1e'. Returning null."  Next update the value field in the AppInstallationProperty table where the ValueKey = ServerReferenceID. Once I changed there fields for the erring apps to the updated database server Guid the apps began working again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now