cannot access internet with Intel 6235 and Comcast wireless router

I installed a new Comcast wireless router and now I cannot get on the internet on my Windows 7 Pro laptop.

All other wireless devices connected to the new Comcast wireless router without issue.   All other laptops use a Dell wireless card.  This laptop has an Intel 6235 wireless adapter.  I ran the network troubleshooter and it gave me a “cannot get DNS information” message.

I assigned a static ip and the DNS server names manually and was able to get on the internet.

Any ideas why I cannot get on the internet when wireless card is set to “Automatically Obtain” ip and DNS information?

Thanks,
cja
cja-tech-guyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
I would power cycle the comcast modem, and your laptop (set to dhcp/ auto ip/dns before you restart) and try again.

If still not working, try to compare the start > run > cmd > ipconfig /all
output of both the working and non-working laptop (or copy paste results here).
jorge diazSECommented:
i'm assuming you were able to connect to the internet. Did you create a new SSID  for comcast or you used the same from before, if so delete the wireless network from windows and rejoin. Update the wireless card drivers, as stated by Kimputer, check your ip settings when connected. Are you getting something like 169.254.x.x?
cja-tech-guyAuthor Commented:
I o not have access to this laptop today.  I will post as soon as I do.

Thanks,
cja
cja-tech-guyAuthor Commented:
I found the solution on a Google search, see below.

Changed the following settings on the wifi card properties.

1.        802.11n Channel Width for 2.4... 20 Mhz Only
2.         Bluetooth AMP... Disabled
3.         Fat Channel Intolerant... Enabled
4.         Roaming Aggressiveness... 1. Lowest

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cja-tech-guyAuthor Commented:
I found the answer by doing a Google search.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.