Linux daemon

:~ # ps -ef | grep slapd
root     16555     1  0 Mar30 ?        00:00:00 ./slapd
root     18860 18363  0 13:28 pts/1    00:00:00 grep slapd

how do i stop this service?

How do i find which binary was used to start this service?

I would appreciate if you can provide some details on how to check this
linuxpersonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
which slapd

that should give you the binary location
check other terminal or graphical sessions; the process was probably executed in one of those
you can always do kill -9 16555 to terminate it
0
linuxpersonAuthor Commented:
when i ran  which slapd i am getting the following


which: no slapd in

I wanted to let you know that i installed open source version which i compiled from source code.

/openldap/openldap-install/libexec/slapd

this is where is my binary executed from

I have made some changes to slapd.conf in /openldap/openldap-install/etc/openldap

for the changes to take effect i would need to start this daemon.
0
linuxpersonAuthor Commented:
i wonder if i do this i won't corrupt anything.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

linuxpersonAuthor Commented:
after i kiiled i am not able to start the slapd again

./slapd: error while loading shared libraries: libdb-4.8.so: cannot open shared object file: No such file or directory
0
Jan SpringerCommented:
When it's running:
   lsof | grep slapd


What is the error?:
  grep slapd /var/log/messages
0
Seth SimmonsSr. Systems AdministratorCommented:
what linux distribution?
0
gheistCommented:
"locate slapd"
find / -type f -name slapd
0
linuxpersonAuthor Commented:
i wrote init start up script/stop script
0
gheistCommented:
normally one can install openldap server with all scripts from system's package repositories...
0
linuxpersonAuthor Commented:
i did download the following version of openldap and installed using TLS option.

openldap-2.4.40.tgz

env CPPFLAGS="-I/openldap/db4/include" LDFLAGS="-L/openldap/db4/lib" ./configure --with-tls --prefix=/openldap/openldap-install

when i tried to start the ldap i am getting TLS not supported error in my log file.

 Apr 27 13:49:48 slapd[21444]: @(#) $OpenLDAP: slapd 2.4.40 (Apr 27 2015 11:35:40) $   root@server:/openldap/openldap-2.4.40/servers/slapd
Apr 27 13:49:48 slapd[21444]: daemon: TLS not supported (ldaps://x.x.x.x)
Apr 27 13:49:48 slapd[21444]: slapd stopped.
Apr 27 13:49:48 slapd[21444]: connections_destroy: nothing to destroy.
0
gheistCommented:
Install with yum, apt, emerge, pkg, msi - USING YOUR SYSTEM's PACKAGE MANAGEMENT
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.