Can't get Hyper-V Windows 2012 STD VM out of STOPPING-CRITICAL State

I have Hyper-V running on a physical box running 2012 Datacenter R2. I attempted to install a new VM for Windows Server 2012 STD and unfortunately tried to attach it to the Broadcom NIC in my physical server. I know of problems with the Broadcom NIC - but forgot to create a legacy network adapter prior to installing the Server 2012 OS. Now the machine is virtually STUCK in STOPPING-CRITICAL mode.

I've tried to kill the process using Microsoft's PROCESS EXPLORER running as administrator. No go - I receive an access denied error trying to kill the process. I've tried to stop and restart the Hyper-V management service. No go - VM shows up in same state after a service restart. Tried to reboot the physical machine - reboot seems to hang indefinitely at the "Stopping Hyper-V management services..." screen and I'm forced to physically shut the machine down.

Kind of at a loss here on how to get the VM to stop. Any suggestions would be appreciated!

Russ Foszcz
rfoszczAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
you can change the network settings while the machine is running. or temporarily change the broadcom virtual switch to private or local. or boot into safe mode and rename the .vhdx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rfoszczAuthor Commented:
Dave Johnson was exactly correct - and I actually hit on this solution myself! I had to reboot my host machine, then when the VM's state changed to RUNNING (from STOPPING-CRITICAL), I was able to disconnect the NIC from the host's NIC and shutdown the machine successfully. Once in a shutdown state I was able to install a legacy network adapter and things are running fine now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.