Testing SQL connectivity from a workstation

Hi
I know my way around a SBS (2011) but not SQL (2008 r2)
I only need to test connectivity from a workstation, someone else is going to come in and handle the configuration.
I've found this post http://microsoftplatform.blogspot.co.uk/2010/12/test-remote-sql-connection-very-quickly.html
which seems to do what I require. I run this on the server and I can see the databases fine.
I run it on the workstation and it only shows me the server name and if I hit the test connection I get
Test connection failed because of an error in initialization provider - Server does not exist or access denied.
I've opened ports 135, 1433, 1434, 2383 & 4022 & ran Cliconfg.exe on both server & workstation and moved TCP/IP to the top of the list.

Now it's time to hand this issue over to some experts before I break something!
sp0ttaAsked:
Who is Participating?
 
DBAduck - Ben MillerPrincipal ConsultantCommented:
On connectivity issues, if you can run the same test on the server and it connects, the problem is a closed port as long as TCP/IP is enabled.

But to tell, you need to go to the server and run the SQL Configuration Manager and go into the Network Protocols section on the left and when it is expanded, look for the Protocols for INSTANCENAME (which would be MSSQLSERVER for a default instance or the NAME of your actual instance) and look to see if TCPIP is enabled.  If it is then you will right click on it and choose Properties then click on IP Addresses tab and go to the very bottom.

Look for the Dynamic Ports value and the Port value.  What are they?  

If the Dynamic Port is 0 then it will assign a dynamic port whenever SQL starts up. It is not guaranteed to be the same. If it is a dynamic port, then you will want to ensure that SQL Server Browser service is running and that UDP port 1434 is open to that server so that browser can pass the dynamic port to the client making the test.

If it has a specific port that is NOT 1433 then you will need to ensure that port is open.

Let's start there.
0
 
Daniel WilsonCommented:
If it shows you the server name, there's a basic level of communication.  A closed port is not the problem.

Probably the server is denying remote TCP/IP connections.  That is, I think, the default setting in recent versions.
0
 
sp0ttaAuthor Commented:
Hi
Allow remote connections to this server is ticked under Management Studio > Server properties > connections
Is there anywhere else I should also check?
0
 
Daniel WilsonCommented:
OK, probably permissions.

By default, the server uses only Windows Authentication.  On the remote machine, are you logged on as the same user ON THE SAME DOMAIN as you are when trying it on the server?
0
 
sp0ttaAuthor Commented:
yep.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.