Internet access

One of my computers can't access the internet through Internet Explorer or Google.  The unit is part of my "Home" network, operating Windows 7. I can send and receive email - Microsoft Exchange Server on Office 365. The other two units can access the internet via  Internet Explorer or Google. IP address are dynamic. Changed the non-access unit to static with same results.
DrEddieSAsked:
Who is Participating?
 
JohnBusiness Consultant (Owner)Commented:
Scan thoroughly for viruses with your own AV application and then with Malwarebytes. After the scan is complete:

1. Please report on results.
2. Run TCP/IP Reset and DNS Flush.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer
0
 
JohnBusiness Consultant (Owner)Commented:
On the problem computer, look in the hosts file (c:\windows\sytem32\drivers\etc\hosts and see if there are entries there. All entries should be comments (except for one 127.0.... local host entry).

You could have a virus on the problem computer.
0
 
Axis52401Security AnalystCommented:
It does sound like a virus. I would set the Internet Explorer and Chrome settings back to default as a virus will often configure a proxy server for Internet access which you don't have and don't want configured.
0
 
DrEddieSAuthor Commented:
Copy of "host" file from computer:
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#      127.0.0.1       localhost
#      ::1             localhost

Also, can't ping internet explorer or google
0
 
JohnBusiness Consultant (Owner)Commented:
@DrEddieS  - Thanks and I was happy to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.