Link to home
Start Free TrialLog in
Avatar of office_equipment_center
office_equipment_centerFlag for United States of America

asked on

Server 2K12 R2 Fax & Scan

Anyone know how to delete/remove any faxes that might be getting sent out by a workstation to clear the send queue?
Avatar of Lionel MM
Lionel MM
Flag of United States of America image

I assume the workstation is sending it to a fax server on a 2012 Server? And I assume you have tried to use the fax interface to try to delete it and it is not working? If these assumptions are correct then you need to go to the server folders and remove them there--with with "del" command from a command prompt of with windows explorer. Do you know where your fax server folders are? If not start the fax GUI on the server and them choose options and then advanced tab and not where the folders are
Avatar of office_equipment_center

ASKER

That is correct. The thing is there is no outgoing faxes on any workstation/server. At least in terms of them showing anything going out. Once I connect the modem the fax server/service picks it up and constantly puts it into a sending mode. However there is nothing sending. I have removed the role and re-added to no avail.
How many PCs have the faxing setup and what version of Windows do they ahve?
15 PCs running either Windows 7 Pro or Win 8.1 Pro. The Server is 2012R2 Standard
OK just so that I am clear
1) When you uninstall fax/scan server on server 2012 there are no errors or no faxes in the outbox on any of the 15 PCs or the server?
2) When you reinstall the fax server you get attempts to send out a fax?
3) This is a new problem--you were able to send faxes before without this behavior?
If the above are correct, have you tried removing the fax modem or a different fax modem?
Sorry for the delay in responding. To address your questions:
1) There are no errors reported when uninstalling the fax/scan server. There are no faxes in the server's outbox. we have not checked all 15 of the workstations however.
2) As soon as the fax server is reinstalled, "something" immediately attempts to use the modem. The reason I say "something" is that the modem is clearly having activity, however, there is no fax showing in the Outbox.
3) Yes, this is a new problem. This had been working fine for about 5-6 weeks with no issues.

We have tried removing and reinstalling the fax modem, but have not at this point tried a different fax modem.
The reason I say "something" is that the modem is clearly having activity
IF you leave it alone does this activity stop or go away? Is the activity actually sending faxes or trying to send faxes? And do you hear the fax dialing and making the fax connection noises? What brand and model fax is it?
No, the activity never stops. There does not appear to be any attempt to send faxes that we can tell. We do not hear the fax dialing or making connection noises.

The modem is a Rosewill RNX-56USB
So then what is this activity that you are seeing?
I really appreciate your sticking with me on this.  

We see the status on the Microsoft Fax Service Manager showing activity (yet there is nothing showing up in the Windows Fax and Scan application). The indicator lights on the modem are also showing activity.

I will take one of your previous suggestions and pick up another modem over the next day or two and put it in place to make sure it is not a malfunctioning modem.
ASKER CERTIFIED SOLUTION
Avatar of Lionel MM
Lionel MM
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I tried the modem again before moving it, and interestingly, it worked OK. I was able to send and receive faxes OK. However, Windows Fax and Scan is only working on the server. None of the users are able to connect to the fax account on the server any longer. When I tried to add them, it said that they did not have permission. I looked at the server and the Windows Fax Service Manager is clearly not showing everything that it normally shows when working. I have attached two images to demonstrate this.

This weekend I will attempt to turn off the fax role on the server and turn it back on again to see if that gets things a little more normal.

User generated image User generated image
I turned off the Fax Role on the server, restarted the server and turned it back on again. There was no difference. Everything looked as it does in the first screen image above. Another thing that I noticed is that AD seems to no longer have the Fax Users, Fax Operators, Routing Assistants Groups that you would normally see.

I have since turned the fax role off again on that particular server. I added the fax role on a different server (again 2012R2 Standard). Now the Fax Service Manager looks more normal (like the second screen image above). I can send and receive faxes from Windows Fax and Scan on the Server. However, I still cannot add the Fax Account in Windows Fax and Scan on User's PCs. It says that they do not have permissions. I have manually added the users into the Accounts section of the Windows Service Manager and that still didn't help.

I still do not have the Security Groups that I would expect in AD. Can the Fax role only be run on a domain controller? I tried to manually create the Fax Users, Fax Operators and Routing Assistants Groups and to manually add my users into those. Still does not work. I get the same permissions error on the user's PCs when I try to add the account into Windows Fax and Scan.

Does anyone have any ideas?
OK but before we move onto a new problem can you now verify that the fax modem was moved to another server and that the fax modem is now working differently and properly in its new location? Fax role, when possible, should not be on domain controller but in small networks where you can't have a server for each maj0r role/application this is possible and feasible.
As to the problem of the user's PC not being able to create a fax and scan account, are you logging on as a domain admin to set it up for the PC or as a limited user? If limited try a domain admin user instead.
The fax modem was moved to the other server. So, it is the same fax modem that I had been using on the other server. As noted above, I am able to send and receive faxes on the new server with no problems (as I had been able to do on the old server as well). It just seems to be the users who are affected. I can't set up the Fax Account in Windows Fax & Scan. It just keeps giving the permissions error.

I understand about not being on the domain controller. This is a small network with only one physical server. This customer's previous server was a 2008R2 Foundation which they outgrew. Their current box is running 2012R2 Standard as a VHost with two VMs, one the DC and the other for their Apps. The server that I moved the Fax Role to is another VM on the same physical server.
so same fax modem, same symptoms, same physical server, different VM--I thought you said you were going to try a different modem over the weekend? if you are getting the same results on a different server then it may actually be a problem with the fax modem. on the other vm server do you still get the "trying to send faxes" problem. as far as setting up the fax account on the PCs I was trying to say use a domain user, that is USER not the the server but on the PCs since you are getting a permissions issue when trying to set it up try a domain admin user to install the fax account on the PC
I checked the user where I was trying to set up Windows Fax and Scan. She was a limited user. So, I tried adding her to the Domain Admins group, logged her out and logged back in. I was still unable to set up the account in Fax and Scan. I have removed her from the Domain Admin group.
so same fax modem, same symptoms, same physical server, different VM--I thought you said you were going to try a different modem over the weekend?
I was going to try as different fax modem, but that doesn't seem to be the issue since I can send and receive faxes fine from either server. The issue seems more related to getting the user's PCs to be able to create a fax account on the server.
This issue morphed over time from the original issue. So I have accepted "lionelmm"'s earlier suggestion as the solution. The later issue where the user's could not authenticate to the Windows Fax Service Manager was never resolved. The customer opted to put a fax modem into an MFP rather than to continue to pursue using Windows Fax & Scan.

Thank you to lionelmm for your assistance.