linux mint and windows AD

I have linux mint installed and joined domain.All are ok. But if i try to under firefox login our intranet(sharepoint windows 2012)web site then my user name and password cant accept .

where i do mistake?
apollo-13Asked:
Who is Participating?
 
rindiCommented:
As far as I know, in order to access sharepoint, you need ActiveX, and that requires an m$ OS along with IE. I don't think it will work with Firefox (on any platform). On m$ platforms you can use a firefox addon "IE Tab" (or something like that), which in effect loads an IE tab within your firefox browser. But this of course won't work under Linux.
0
 
apollo-13Author Commented:
thanks, itried ie tabs ,but not working
0
 
rindiCommented:
As I mentioned, IE Tabs just uses Internet Explorer when you are connecting to sharepoint when using a windows PC. But linux doesn't use the internet explorer and nor does it have ActiveX, so IE Tabs won't work under linux.

One option that might work somehow, is to use PlayOnLinux (which makes using wine easier), and then install Internet Explorer and ActiveX under that. But I don't know whether ActiveX is even available for wine.

The other option that will work, but will also use plenty of resources and a windows license, is to use VirtualBox and install a Windows VM under that.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
apollo-13Author Commented:
you are right.I installed wine but no option active x. Do you really think my problem is activex ? can be NTML authentication between linux and sharepoint( windows active directory also)?
0
 
rindiCommented:
Yes the problem is activeX. That is one of those m$ "features" which forces you to use m$ software.
0
 
apollo-13Author Commented:
i found something and will testen ,adobe schockwave active-x
0
 
gheistCommented:
by ways of joining domain - did you nebale kerberos support too? That will allow mutual authentication at least for smbclient. Maybe for firefox too.
0
 
apollo-13Author Commented:
did you nebale kerberos support too?--no
do i need to install smbclient too?
0
 
apollo-13Author Commented:
this guiede i found.

Enabling Kerberos Authentication in Firefox
Firefox does not automatically perform Kerberos authentication against any sites. You must manually add sites to a trusted sites list.

To enable Kerberos authentication in Firefox:

Open Firefox and enter about:config in the address bar. Dismiss any warnings that appear.

In the Filter field, enter negotiate.

Double-click the network.negotiate-auth.trusted-uris preference.

This preference lists the trusted sites for Kerberos authentication.

In the dialog box, enter the PeopleSoft domain, such as example.com.

Click the OK button.

The domain that you just entered in the network.negotiate-auth.trusted-uris should now appear in Value column. The setting takes effect immediately; you do not have to restart Firefox
0
 
gheistCommented:
check in /tmp for *ccache** files
If there is any you have kerberos enabled with all ticket refresh needed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.