Cannot connect to SQL server

After a power outage that powered off the domain controller, which came back online with no errors, I cannot connect to my two SQL servers. The attached is what shows when attempting to connect.

The error only shows when Authentication is set to Windows Authentication and from a client workstation. Locally on the server I can connect using Windows Authentication.

Here are the details of the event log on one of the servers, SQL 2008:

Log Name:      Application
Source:        MSSQLSERVER
Date:          4/1/2015 11:23:49 AM
Event ID:      17806
Task Category: Logon
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      VPX-DB.vpxsports.local
Description:
SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.0.4.50]
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSSQLSERVER" />
    <EventID Qualifiers="49152">17806</EventID>
    <Level>2</Level>
    <Task>4</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-04-01T15:23:49.000000000Z" />
    <EventRecordID>177278885</EventRecordID>
    <Channel>Application</Channel>
    <Computer>VPX-DB.vpxsports.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>8009030c</Data>
    <Data> [CLIENT: 10.0.4.50]</Data>
    <Binary>8E45000014000000070000005600500058002D0044004200000000000000</Binary>
  </EventData>
</Event>
errorSQL.jpg
VPXITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle AbrahamsSenior .Net DeveloperCommented:
I would try restarting the sql service and failing that reboot the machine.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Did you try to restart the SQL Server after the DC restarted?
0
VPXITAuthor Commented:
Reboot of the SQL server done after restarting the domain controller done and no resolution.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Can you check the SPN for the SQL Service account?
0
VPXITAuthor Commented:
I'm not too familiar with the command but I did SETSPN -R VPX-DB and there were no errors.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
For now just list the SPN for the SQL Server account. See if it exists any entry:
setspn –l accountname
0
VPXITAuthor Commented:
Registered ServicePrincipalNames for CN=VPX-DB,CN=Computers,DC=vpxsports,DC=local:
      MSSQLSvc/vpx-db.vpxsports.local
      MSSQLSvc/VPX-DB.vpxsports.local:1433
      Microsoft Virtual Console Service/VPX-DB.vpxsports.local
      Microsoft Virtual Console Service/VPX-DB
      Microsoft Virtual System Migration Service/VPX-DB.vpxsports.local
      Microsoft Virtual System Migration Service/VPX-DB
      MSSQLSvc/VPX-DB.vpxsports.local:GP2013
      MSSQLSvc/VPX-DB.vpxsports.local:49927
      MSSQLSvc/VPX-DB.vpxsports.local:56879
      tapinego/VPX-DB
      tapinego/VPX-DB.vpxsports.local
      WSMAN/VPX-DB
      WSMAN/VPX-DB.vpxsports.local
      TERMSRV/VPX-DB
      TERMSRV/VPX-DB.vpxsports.local
      RestrictedKrbHost/VPX-DB
      HOST/VPX-DB
      RestrictedKrbHost/VPX-DB.vpxsports.local
      HOST/VPX-DB.vpxsports.local
0
VPXITAuthor Commented:
...just as an attempt I removed my workstation from the domain, deleted the workstation object from AD, and added the computer back to the domain and no go. I'm leaning more towards there being something at the domain/AD level since the same behavior is seen on both SQL servers.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
I'm out of ideas. Added some other topics to see if some Expert from those areas can help you.
0
VPXITAuthor Commented:
There has not been any solutions and I believe this is something on my domain. It is offers any additional information, attached is a log as a result of executing 'nttext /dbflag:0x2080fff' on my terminal server which is not allowing domain users to log in.
0
VPXITAuthor Commented:
KB3002657 installed on VPX-DC1 was causing the NETLOGON issues.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Issue solved?
0
VPXITAuthor Commented:
Yes.  The issue was solved with removing the Windows update from the domain controller.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
VPXITAuthor Commented:
The issue started when Windows update KB3002657 was installed on the domain controller.  With having this update removed the issue was resolved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.