Outlook 2013 instant search (no cache)

Outlook 2013 will not return any result in instant search. We are cannot turn on cache mode, that is not an option. Please let me out I am stuck in the middle of the water here
LVL 2
Jermaine BhoorasinghJr. Operations EngineerAsked:
Who is Participating?
 
Alexa JacksonDigital Forensic AnalystCommented:
Hi Jermaine Bhoorasingh,

This issue was may be related to a corrupted Exchange Search index file.

A recreation of this file will solve this problem. To do this:

•      Stop the following services on the server where Exchange 2013 is running. Microsoft Exchange search and Microsoft Exchange Search Host Controller.

•      Browse to the following path #:\Program Files\Microsoft\Exchange Server\Mailbox\Mailbox Database < name of the database file (numbers)>

•      In this folder is a folder located named like: ########-####-####-####-###############.1.Single

Rename this map. to ########-####-####-####-###############.1.Single.old

Note: For renaming this folder it’s important that the services in step 1 are stopped.

•      Start the services: Microsoft Exchange Search and Microsoft Exchange Host Controller. The Exchange server will now rebuild the index file. This process could take some time. To view the status of this process, execute the following steps: -

1.      Start Microsoft Exchange PowerShell program

2.      Use the following command: Get-MailboxDatabaseCopyStatus

The ContentIndexState will change during this process from failed to crawling and effentially to healthy. If this is not the case then an error has occurred during the rebuild.

Thanks and regards
Alexa@J
0
 
Dejan VasiljevicSys Admin and ProgrammerCommented:
Remove Outlook from Index

Go to Outlook Settings (File | Options)
Go to the Search settings
Click on Indexing Options
Click Modify and deselect Microsoft Outlook
Click Close to dismiss dialog box
Exit Outlook

Ensure Outlook Files Can Be Indexed

Any Outlook OST or PST file that you’re using must be allowed to be indexed by Windows.  This is a default file attribute when Outlook indexing is enabled.

Find all OST and PST files that you’re using on your computer.  In Windows 8, OST files are usually hidden and stored in the C:\Users\[username]\AppData\Local\Microsoft\Outlook folder.
For each file you’re using, right click on the file(s) and select Properties
Click on the Advanced button on the general tab
Ensure that the Allow this file to have contents indexed in addition to file is checked.Click OK.

Re-Add Outlook to Index

Now follow the same steps in the first section and re-add Microsoft Outlook to the search index.  Start Outlook, go to the Indexing Options, and add Microsoft Outlook back to the list.

Rebuild Index (Optional)

To rebuild the index:

Go to Outlook Settings (File | Options)
Go to the Search settings
Click on Indexing Options
Click Advanced
Click Rebuild
Click OK and then Close to dismiss the dialogs
Indexing will run for a while but quick search should begin working shortly, using whatever index has been built thus far.

Thanks,
D.
0
 
Alexa JacksonDigital Forensic AnalystCommented:
Hi,

As per the information and details provided by you, to solve the problem of Outlook 2013 instant search, please follow these steps: -

Step 1: - Marked for Indexing

First let us check if the PST-file or Mailbox has been marked to be indexed.

Outlook 2013
File > Option > section Search > button Indexing Option > button Modify


Here, make sure that Outlook is selected.

Step 2: - Check for PST-file Corruption

If your pst file has been marked but Outlook does not display the correct results, it usually means your pst file gets corrupted and to fix it you can use scanpst.exe.

Once repaired, open Outlook and leave it idle for some time. To see if everything has been indexed now use: -
Outlook 2013: - Click in the Search field in order to make the Search Tools tab visible in the Ribbon. Here click the Search Tools button and select the Indexing Status.

Step 3: - Disable and then re-enter the file for Indexing

Go back to Search Options and deselect the data file that is giving you issues. Close Outlook and wait. And also verify in Task Manager that on the Processes tab the Outlook.exe process actually quits.
After this option Outlook and go back to the Search Option and select pst file we just deselected.

Step 4: - Rebuild the Index

If it does not, it might be that the Index itself has been damaged. In order to reset this, go to Control Panel > Indexing Options > Advanced > button Rebuild.

Step 5: - Reset the Index
If it still does not work press the “Restore Defaults” button under Rebuild button in Windows Vista. In Windows 7 and 8, you can press the blue Troubleshoot search and indexing link. In this you can select the option Email does not appear in search results.

Step 6: - Reinstall the Windows Search Features
Step 7: - Check Event Viewer and post in the newsgroups
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Jermaine BhoorasinghJr. Operations EngineerAuthor Commented:
It wasn't a problem with the client. The problem was with the exchange server. Your solution also made note of ost, we can not use cache mode.
0
 
Jermaine BhoorasinghJr. Operations EngineerAuthor Commented:
This issue was worked on my senior, but I believe the steps taken were similar (the end result is the same: rebuild content index)
0
 
Dejan VasiljevicSys Admin and ProgrammerCommented:
Hi Jermain,

Next time, please take in dept look at my solution please. Because I've posted rebuild index solution inside my first solution named - Rebuild Index (Optional)  
Rebuild Index (Optional)

To rebuild the index:

Go to Outlook Settings (File | Options)
Go to the Search settings
Click on Indexing Options
Click Advanced
Click Rebuild
Click OK and then Close to dismiss the dialogs
Indexing will run for a while but quick search should begin working shortly, using whatever index has been built thus far.

Please take a look before You close case...

Thanks,
D.
0
 
Jermaine BhoorasinghJr. Operations EngineerAuthor Commented:
Dejan,
You are failing to understand that the issue was not with the outlook client. It was on the Exchange server.

I clearly said we are unable to use cache mode. OUTLOOK 101 .ost file are created when cache mode is enabled, I completed ignored your answer because you were not addressing my question. Alexa pointed out how to rebuild the content index of the mailbox database ON THE EXCHANGE server.

For future reference, please make sure you understand the problem before trying to solve.

Alexa deserves all the points because  she was the only one with a solutions that would apply
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.