Error when running VS apps

I'm getting this error when running some VS apps.    Just a few days ago I was running OK.   I have since downloaded the 2010 Web Deployment tools and Azure publish tools, but decided not to use them and uninstalled from the system.  

Anyone have a thought on this?



VS error
LVL 1
HLRosenbergerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bob LearnedCommented:
1) Project type?

2) What versions of SQL Server CE do you have installed?

3) What were you trying to do when you got this message?
HLRosenbergerAuthor Commented:
1) WEB site.

2) How would I determine this?

3) I open the solution, and run it.  I only get the message once, when I run; on subsequent runs, it does not occur. If I close VS and then re-open the solution, I again get the message on the first run,.
Bob LearnedCommented:
The versions are shown in the installed programs section on the Programs and Features (Windows 7).

Program and Features Showing SQL Server CE version
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

Bob LearnedCommented:
Have you tried repairing Visual Studio, and reinstalling any service packs/updates?
HLRosenbergerAuthor Commented:
ok, I went in and uninstalled all versions of SQL Server Compact, because I do not use it .

I still am getting that message.
Bob LearnedCommented:
What external/3rd party controls and/or assemblies are you referencing?
David Johnson, CD, MVPOwnerCommented:
check your connection strings.. you say you are NOT using Compact but your project thinks that you are.  you should download and use the Visual Studio Community
HLRosenbergerAuthor Commented:
yes, something is trying to use/add Compact to my project; I am not using it.

I do have a connection string for Compact in my web.config.
Bob LearnedCommented:
What is your connection string, with private information removed?
HLRosenbergerAuthor Commented:
<add name="DatabaseTNCP" connectionString="Data Source=192.168.1.13;Database=xxxx;Trusted_Connection=no;User Id=xxxx;Password=xxxx" providerName="System.Data.SqlClient" />
HLRosenbergerAuthor Commented:
I do think it's related to my code; something was installed that did this.
HLRosenbergerAuthor Commented:
I mean,  I do NOT think it's related to my code; something was installed that did this.
HLRosenbergerAuthor Commented:
Problem is solved.   I had  downloaded the 2010 Web Deployment tools and Azure publish tools, but decided not to use them and uninstalled from the system.   But, I had not rebooted.   After a reboot yesterday, the problem went away.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HLRosenbergerAuthor Commented:
A reboot solved the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual C++.NET

From novice to tech pro — start learning today.