Oracle 11G - ORA-15196: invalid ASM block header

Hi,

I am trying to start a ASM instance but Im getting the error below:

SQL> startup
ASM instance started

Total System Global Area  283930624 bytes
Fixed Size                  2227664 bytes
Variable Size             256537136 bytes
ASM Cache                  25165824 bytes
ORA-15032: not all alterations performed
ORA-15130: diskgroup "DATA_DG" is being dismounted
ORA-15066: offlining disk "DATA_DG_0000" in group "DATA_DG" may result in a
data loss
ORA-15196: invalid ASM block header [kfr.c:8514] [endian_kfbh] [3] [8101] [0 !=
1]


If I try to mount it later on I get this:

SQL> alter diskgroup DATA01 mount;
alter diskgroup DATA01 mount
*
ERROR at line 1:
ORA-15032: not all alterations performed
ORA-15017: diskgroup "DATA01" cannot be mounted
ORA-15063: ASM discovered an insufficient number of disks for diskgroup
"DATA01"


So, checking the alert log I found the following: (attached all lines)

ERROR: no read quorum in group: required 2, found 0 disks

====

The kfed read command does not return any error for the DATA01 (attached output)

Have already tried to following but did not work...

kfed write /dev/oracleasm/DATA01 text=/home/oracle/bak.bk
dd if=/dev/zero of=/dev/oracleasm/DATA01 bs=4096 count=1
kdep write /dev/oracleasm/DATA01 text=/home/oracle/bak.bk

And restart the ASM instance but it still fails...

Tried the kfed repair as well..

====

I think the issue might be related to the fact that I expanded a LVM volume where the data was...

To expand the LV I first created a new partition using fdisk (option n and set it as Linux LVM), then I created the physical volume (pvcreate), then used vgextend to add the new physical volume to the existing volume group.

Not sure if I supposed to do it this way....

Anyway, Is there a way out of this?

Tks,
Joao
alert.log
-ASM-rbal-6123.txt
kfed-read.txt
joaotellesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
I would contact Oracle Support.

Attempting to continue to troubleshoot this yourself or through a site like this might cause more problems than they solve.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joaotellesAuthor Commented:
Tks. Contacted the support
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.