Hyper-V Guest (Linux) on seperate VLAN

I am running Server 2012 Datacenter on a 2-node cluster. I have a few Hyper-V guests running successfully.

We have 3 VLANs in place:-

VLAN1 is used by all staff devices (PCs, tablets, phones etc), with DHCP being issued by a Hyper-V guest also running Server 2012 Datacenter
VLAN300 is for Customer PCs only (connected via LAN cable) - IPs are allocated by a Watchguard Firebox XTM515, and are in the range 192.168.101.x
VLAN200 is for Customer Wi-Fi - IPs are (currently) allocated by the same Watchguard Firebox, and are in the range 192.168.100.x. Anyone who connects to VLAN200 has to authenticate, and this authentication is handled between the Firebox and an Ubuntu Linux box running Apache and Python. The Firebox passes some data to a python script which then passes control back to the Firebox.

There are a total of 13 Watchguard AP200 units on the physical network handling both VLAN1 and VLAN200

We have intermittent issues with VLAN200 where it suddenly gives up on allocating IP addresses even though the pool still should have plenty to give out. The resolution is to reboot the Firebox (and sometime the connected APs too)

We've had technical support with Watchguard, and they have said that there is a problem with the Firebox handling DHCP on a VLAN Wi-Fi. This has been ongoing for at least a couple of years, so far with no fix.

All of the VLANs, for the majority of time, work well.

However, what I want to do is virtualise the Linux unit so that it runs as a Hyper-V guest but on VLAN300 and this is where my problem lies.

I have the Hyper-V Linux guest installed and I have enabled the VLAN Identification and set it to 300, but it will not communicate with anything on the same VLAN. The ports on the Netgear GS752TPS switch that the 2 Hyper-V hosts connect to have been configured as trunk ports for VLAN300.

I need to get this running so that I can eventually install DHCP services on this Linux box to take the function away from the Firebox.
LVL 17
Chris MillardAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
Where are.you setting VLAN 300 for the Linux VM? If your hosts bare using trunk ports, then the VLAN ID should be set on the virtual network card in Hyper-V Manager. If you are not using trunking, then the physical NIC of the host needs to be dedicated to VLAN 300 and the switch port be set to an access port for VLAN 300. The fact that it is Linux doesn't change any of this.

It is possible that your Linux VM isn't configured properly. Have you tried setting it to DHCP? Have you specifically enabled the Hyper-V drivers in the VM? Try installing the legacy NIC. Linux will certainly have that driver.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Chris MillardAuthor Commented:
I'm not familiar with VLANs on Hyper-Vs at all, and all I have done is enable VLAN Identification through the settings section of the Hyper-V guest, and have put the VLAN ID of 300 in there.

The physical switch port that the host connects to has been set as a trunk port for VLAN 300 traffic.
kevinhsiehCommented:
Please post the configuration of the switch port. If you set  the native vlan of the switch port to 300, that conflicts with the setting of the guest. Do not set the native vlan of the trunk port.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Chris MillardAuthor Commented:
Just as a follow up, I have tried doing the same with a test Windows Hyper-V guest (just setting the VLAN ID to 300) and it doesn't seem ti get any network connectivity either.

The physical switch port (on the NetGear GS752TPS) has it's PVID set to 1, and is untagged for VLAN 1. I have tried with untagged and trunked options for VLAN 300, but neither seem to be working for me.
Chris MillardAuthor Commented:
OK, I don't know what to say here. I've just set the port back to trunked mode again and this time, both my Linux and and Windows guests are now working on the VLAN.

I'm stumped as to why it has only worked now.
Chris MillardAuthor Commented:
Thanks for all of your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hyper-V

From novice to tech pro — start learning today.