vCenter using openLDAP

I am using vCenter to authenticate users using openLDAP 2.4 version which i have installed on my domain.

i am using vCenter as appliance and openLDAP installed on SUSE linux.

I am able to connect to openLDAP but for some reason i am not able to see the users in Vcenter.

need some assistance.
linuxpersonAsked:
Who is Participating?
 
linuxpersonAuthor Commented:
i had problem with the schema. i had to remove account schema and add inetorgperson schema.

its works now.
0
 
Alessandro ScafariaInfrastructure Premier Field AdministratorCommented:
0
 
linuxpersonAuthor Commented:
Hi Alessandro.

Your post was showing AD as a LDAP services.

Actually, I downloaded openldap source code, compelled and install it on suse linux.

I am using Oracle Berkeley DB as database.

when I connect to my ldap using jxplorer i am able to connect with no issue. When i connect using vCenter, i am able to add the identity source but i am not able to see any user accounts.


Apr  3 15:02:01 xxxxx slapd[19220]: conn=1185 op=0 RESULT tag=97 err=0 text=
Apr  3 15:02:01 xxxxxx slapd[19220]: conn=1185 op=1 SRCH base="ou=People,dc=unix,dc=mydomain,dc=net" scope=2 deref=0 filter="(objectClass=inetOrgPerson)"
Apr  3 15:02:01 xxxxxx slapd[19220]: conn=1185 op=1 SRCH attr=uid description givenName sn mail userAccountControl pwdAccountLockedTime entryUUID
Apr  3 15:02:01 xxxxx slapd[19220]: conn=1185 op=1 SEARCH RESULT tag=101 err=0 nentries=0 text=
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
linuxpersonAuthor Commented:
userAccountControl pwdAccountLockedTime ????? I am not sure
0
 
MazdajaiCommented:
Do you have the correct base DN for users / groups?

Can you post a screenshot of the user account page where it is blank? What happen if you click on "test connection" on the identity source page?
0
 
MazdajaiCommented:
How is this going?
0
 
linuxpersonAuthor Commented:
i did solve my self
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.