Network drive disconnects Windows 7 Pro

This is in re Windows 7 64 bit clients of a Windows 2000 Server domain.
Wrong, yes, but it's not my name on the building...
I have had no issues adding these Windows 7 clients to the domain nor any network disconnect issues until this latest machine.
But the question is this. I found a solution that says to do this to solve the problem:

net config server /autodisconnect:-1

from a command prompt on the Win 7 box in question. I'm not clear if this has impact on the server side or just in the unique trust relationship between this workstation and the server only. That's my base question. Does running this command impact the entire network?

Now, the background. I have set all the power settings on the network adapter to never power down, and I also do not let the drives sleep or hibernate. This one machine disconnects network drives that are mounted with a log in batch file:

@echo off
net use I: \\linus\Shared
net use H: \\linus\pranum$

Once the drives are disconnected, they do not reconnect, nor is there a certain amount of time needed to pass for this error to happen. I can reach the machine remotely. Start/Computer opens the window, Drive C comes up, and the network shares display as icons with small green lines on them, but no display of drive usage bars as is normal. Then a green progress bar comes up in the explorer window and slowly moves to the right. The drives never mount. Conversely, if I do nothing, eventually the prblem appears self healing only to occur again with no rhyme or reason to it.
 I have ruled out network line trouble, network adapter, and trouble at the switch. The problem follows the machine in terms of network location and network adapter. I have both an on-board and PCI Express mounted adapter, and both behave the same way. I suspect a Windows setting has been altered as some users need to be local admins, but I can't find it anywhere.
I would prefer to have a command line option that reverts the network settings on the local machine to defaults rather than the command listed above. I appreciate any ideas you have. Thank you.
afrendAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CompProbSolvCommented:
Nothing obvious to me here, but some things to consider.

You mention that these drive letters are mapped through a batch file.  What happens if you map them in Windows Explorer?  Do they map?  Do they experience the same disconnection?

I'd be very suspicious of some sort of sleep or hibernation going on.  Make sure those are set to "Never" and to "0" (the latter in the Advanced settings under Power).  I would also confirm that the NIC does not allow the system to shut it down for power saving.
0
afrendAuthor Commented:
Actually, those two drives are connected via batch file, and another drive on another server that is a member of the same domain has a share mounted via Explorer with option "reconnect on login" checked. That drive behaves the same, and that's the most troublesome one as it connects to an application server running Visual Fox Pro. VFP really doesn't like that behavior...

I have been over this machine's power saving options as well as the same with the network adapters. As you say, nothing obvious here. If there is some sleep or hibernation at work, then that begs the question as to why the network "awakes" as evidenced by remote connectivity, but the attached drives do not, as expected.
0
CompProbSolvCommented:
I am not shocked that sleep or hibernation could cause trouble with a drive mapping though not with basic connectivity.  Of course, it should behave properly in both cases but life/computers aren't always as they should be!

Does this problem occur only when the client computer has been left idle for an extended period of time?  Did you also check the "advanced power settings"?  I've had that one bite me before.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

afrendAuthor Commented:
It was brought to my attention by a night shifter shortly after I deployed the machine that I hadn't a lick of trouble with when building it. I use them myself for a week before delivering them to the users and I had no issues. As it is told to me, she would go to lunch, leave the Fox Pro application open, and lock the workstation. She would come back from lunch to the problem. I would come in the next day to a miracle healing and could NOT recreate the problem. Others suggest that locking the workstation automatically disconnects network drives by default in Windows 7, but that has not been proven out here on any other Windows 7 machine.

As I said, I have been over all energy saving settings, basic and advanced, six ways to Tuesday. Nothing.

But more to my original question, I wish to try this, but I'm kind of scared to. I think back to when I put the first W2K machines on the network against the NT4 domain controller and ran into "master browser" conflicts. I really don't want to upset the domain apple cart over this so, the real question remains: Do I want to?

"net config server /autodisconnect:-1

from a command prompt on the Win 7 box in question. I'm not clear if this has impact on the server side or just in the unique trust relationship between this workstation and the server only. That's my base question. Does running this command impact the entire network?"
0
CompProbSolvCommented:
re: "net config server..."
I've not used this, so my comments need to be taken accordingly.

A user on a workstation without Admin rights on the server should not be able to reconfigure such a setting on the server by running the command on the workstation.  As I read one listing on the documentation for this command, it would be run on the server.  In that case, it certainly would make a system-wide change.

Take a look at:
http://support.microsoft.com/en-us/kb/297684
Note the "only on computers with shared services".  That would indicate that this is run on the server, not the workstation.

If you run "net config server" on the server, it will tell you what the idle time is set to.  I would consider noting that time, extending it to a long enough time (120 minutes?) to avoid the lunchtime timeout, and see if that resolves it.  You always have the option of setting it back later.
0
afrendAuthor Commented:
I'll have to look at that, but remember, this is the only computer that exhibits the behavior. Thank you.

See the attachment. The "idle timeout" is set to 15 by default. I can only assume that since other machines, both XP and 7, haven't an issue remaining open to network drives when connected to files and folders, idle means idle.

It appears the workstation in question is ignoring activity on connected drives and turning them off both before and beyond the subscribed server time. Remember, this is Windows 2000 Server at the domain controller level. So I think we have isolated as a workstation and not a server problem.

Again thanks. Good Easter all and we'll pick this back up Monday.
linus.jpg
0
CompProbSolvCommented:
I absolutely agree that this is not a server problem given that all but one Windows 7 computer work properly.  My suggestion was intended to confirm whether or not this idle timeout was the issue.

When you mentioned that you couldn't recreate the symptom, did you follow the same key steps?
1) Leave FoxPro open
2) Lock the workstation
3) Wait long enough (30-60+ minutes?)
0
afrendAuthor Commented:
Yes, I've done all of the above on both the user profile in question and a "clean" profile as well. The user profile as well as the clean profile both have gone past an hour without failure or as little immediately when the workstation is locked. Some times, not. It's very hit of miss, and changing the network adapter produces the same result, so I can only assume as bad or corrupt setting in Windows. I even went into the repair option in Windows, but I really saw no real good option there that points to this problem. I have removed and rejoined the computer to the domain with a different name with no change in the behavior.

At this point, I'm tempted just to wipe the machine completely or put an old image back on it that I think predated the problem. I just don't know if I do a fresh install, do I lose the Office 2013 (from media) installation, or will it go back on the machine since it was installed on there once before? All my vendors can tell me is the installation dies with the machine.

As always with Windows, problem resolution has few options that don't come with hidden costs.
0
CompProbSolvCommented:
If you do a fresh install you will have to reinstall Office 2013, but the license will still apply.

I would not wipe the existing drive as you may find that this is actually a hardware problem.  Perform some sort of full backup (image) or replace the drive with another one before reinstalling.

If I read you correctly, the problem is somehow related to locking the computer.  That is, if you don't lock it, then the problem never appears.  If you do lock it, it might appear right away or after some time.  Have I got this right?

If you don't have FoxPro running, does the problem ever appear?

Does it matter if it locks because of a timeout or if it is done manually?

Once the symptom occurs, are you able to ping the server?  Can you browse to the server and shares?  Can you disconnect and reconnect the mapped drives?

Anything interesting in the workstation or server error logs?
0
afrendAuthor Commented:
At first, that was what was believed to be the problem, locking the workstation,  when explained in other forums.
"Windows 7 automatically disconnects network drives when you lock the workstation!"
They didn't ask if was domain, peer to peer, home network, just declared that to be a fact. Not what I see here in cold hard reality. Maybe they meant "automatically disconnects idle network drives", but couldn't get that far. As I have said, this workstation is unique.

I believe I have played out every possible combination of locked/unlocked, etc. There is no pattern to it other than it is random in time and does not matter the if the Fox Pro application is or is not connected.

I do know that I can reach the machine from and RDC session, and reach other machines from it via RDC sessions without interrupt, so it seems to be tied just to the perceived state of the network drives.

Yes, I can remove and reconnect network drives, both via log in script and hand mapping via My Computer.

Either I really don't know how to read nor understand machine logs, so I can't really answer your question about those. For example, each time I connect to a Win 7 machine via RDC, it tosses up errors in the Win 7 machine logs due to my network printers connected to my computer.
The Security Log on the Win 7 machine should tell me something about the event disconnects, but does not. On the server side, it's Win 2000 with 40+ clients, so by the time I see the problem, if the problem is logged, I am either unable to find it or it is overwritten rather quickly where I would find it.

So, I like the idea of tossing the image on a different hard disk. The problem is getting the boss to buy one.
0
CompProbSolvCommented:
I just did a Google search on this and found a registry setting on the workstation that might do the trick:
http://www.nextofwindows.com/how-to-fix-the-red-x-on-the-icon-of-mapped-network-drives-in-windows-7/

If you export a copy of the key it has you modify you can always put things back to their original state if this doesn't work.  It should be a very quick and easy thing to change.  Time will tell if it resolves your issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
afrendAuthor Commented:
That's interesting. I have 3 Current Control Sets.
Should I?
Please view the attachment.
Thanks.
ccs.jpg
0
afrendAuthor Commented:
I am going to close this and award points. The last thing I did was, under the KISS principle, updated the system BIOS from 1.11 to 1.34.
Nothing.
Hardware diagnostics of the hard disk show clean.
I guess I will try the registry edit recommended under the Control Set that is not numbered. A KB suggests that applying the registry edit to the unnumbered Control Set is the way to go, so I guess I'll try that.
I have looked at a few other Win 7 machines that do not have the problem nor the KeepCon key.
I have an image I can apply going back to 3/11 to try.
And, I can just flush it all and install anew.
If all that doesn't resolve it, I can only assume that this vintage, (XW 4600) of HP while on paper is Win 7 capable, maybe not.
Thanks for the inputs. I'll wait to award points at the end of the day.
0
afrendAuthor Commented:
The registry edit given apparently does not work on a 64 bit system.
QWORD in 64 bit?
0
afrendAuthor Commented:
Very good information from CompProbSolv.
Sadly, the problem was not resolved.
0
CompProbSolvCommented:
Registry edit:
THere is just one "CurrentControlSet" (the one you want to edit.

The others are "ControlSet001" and "ControlSet002".

I would still expect it to be DWORD value.

Did you try creating the key as a DWORD, setting a large value (in seconds), rebooting, and testing?
0
afrendAuthor Commented:
Yes, I did that. (I found elsewhere what the additional Control Sets were for.)
I set a DWORD KeepConn with value of 172800.
Rebooted and it would not start. After a couple of tries, it went into the start up repair. Once completed, that allowed it to boot normally again. I merged the key back into the registry.
I was a little encouraged as it ran for several hours yesterday without disconnects, so I gave it the over night test, and it failed.
At this point, I can only think there is some corruption deep in Windows that I could hunt for even longer, but it's time to move on and give it a fresh install.

This is an XW 4600 HP system. What I find that is curious is that even with both on board and PCI ethernet adapters installed, the PCI adapter seems to take priority. As an example, the boot media for my backup solution is supposed to see any adapter that is plugged in. It only sees the PCI adapter, plugged in or not. When I removed the PCI adapter, it saw the on board once again. Strange.

So it's back to the original hardware, fresh install, and see what happens. If it repeats, then I can look at the hard disk as an issue.

Again, thanks for the input(s). I appreciate it.
0
afrendAuthor Commented:
Ah, how often we look past the simple solution...
Solved. Remember back when used words and phrases like IBM compatible? AT and ATX chassis? Things are much better now, more consistency in manufacturing.
Well...sort of.
I built this kernel off a vanilla Windows 7 64 bit disk. The hardware had a nothing special Netextreme adapter that the installer had a driver with a 2009 date on it. A 2014 driver was easily found on the Netextreme web site.
Apparently, the raw generic driver does not perform as intended on this HP product line. The box in question, XW 4600, has Win 7 drivers available, but the COA on the box is for Vista Pro. The Network Driver package for Win 7 64 bit and Vista 64 bit are the same package. I applied the HP driver installer package against the installed driver, and it's all better now.
FYI
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Analysis

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.