Parallels VM Won't Start After Mac Migration

I have a new MacPro and I did a Migration Assistant from the SSD that I was using on an older Mac. Using the SSD on the older Mac, my Parallels VM worked just fine.

After doing the migration to my new Mac, my Parallels VM will not start.  I get the following error:

Unable to Connect to Hard Disk o.

A file or device required for the operation of Hard Disk 0 does not exist or is used by another process, or you have no permission to access it. The virtual machine will continue running, but the device will be disconnected.

I have looked at several KB articles from Parallels and have tried the following.

I have completely removed and reinstalled Parallels. I have repaired disk permissions. I have tried copying it to a new location in hopes that something would click when I started the program up. I have a copy of it on an external disk that runs just fine, but I know I have made some minor changes since I made the copy and would like to get the real one running.
LVL 28
jhyieslaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Martin LissOlder than dirtCommented:
Have you tried contacting Parallels support? IMO they aren't very good or responsive but it's worth a try. Often their response is "reinstall Parallels Tools". Did you try that?
0
jhyieslaAuthor Commented:
I did, but am waiting for a response... and as you said ...

I can't reinstall the tools as I can't get the VM to boot. I have reinstalled Parallels itself, but that made no difference.
0
Martin LissOlder than dirtCommented:
See Scenario 3 in this article. It might help.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

jhyieslaAuthor Commented:
I just tried that and it will not open in mounter. It's as though the "disk" is totally corrupted, but I ran it just fine yesterday from the SSD on the old Mac, so I'm not sure what the deal is.
0
strungCommented:
Can you just do a finder copy of the Parallels virtual machine from the old disk to the new?

http://kb.parallels.com/en/117333
0
jhyieslaAuthor Commented:
I did that and it also failed.

What I finally did to get me up and running is to copy by back up copy from an external drive to the new drive and that works. It's not 100 % so I need to tweak it, but at least it's running.  I had something similar happen when I went from my old Mac Pro to the new one I had a couple of weeks ago and I solved it by doing the same, but I'd really like to figure out why this is happening and how to fix it so that I could get back to it even if I did not have a back up.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jhyieslaAuthor Commented:
None of the other answers really addressed the final solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.