FMS9 install on Yosemite, can't get Deployment Wizard to run

An OS X 10.4.11 iMac with FileMaker Server 9 (and FileMaker Pro 9) is serving files to a small group of computers.  Someone else set that up.

I’m attempting to replace it / set up a new iMac with Yosemite / 10.10 OS X (64bit), to be a FileMaker Server 9 server.  All the web posts I said I couldn’t use the migration assistant between these OS’s, so I though tI’d go from scratch.

I believe I have installed FMS9, but cannot get to the “deployment wizard”. (I haven’t had a chance to set up an administrator login or password.) Some posts say I need to roll back java, edit Java’s security (did that), try a different browser (did that), tweak browser securities (did that), drop firewall to open port (did that), and so on.  So before I waste more time on the various suggestions I’ve come across, I thought I”d ask experts.
_____________
Here are the details:

I used apple’s remote disc to copy the FMS installer files from the old mac’s dvd drive to my new mac desktop. The filename is “fms_9.0v1_R2_full_ESD.dmg”. This FMS9 installer said I needed JAVA, which I already had. Then it seemed I needed 32bit java, but before I got there I found the download “JavaForOSX2014-001.dmg”, which allowed me to run the FMS9 installer.  But then when I tried the initial run of ht program, I had java security permissions errors, until I entered this into Java’s Exception Sitelist: http://localhost:16000.  

Now when I clicked on the FMS9 start page, it loads a page (url is: file:///Library/FileMaker%20Server/Admin/admin-server/launch-page/prelaunch_single_en.html), which says “please wait while the Admin Server starts” but never proceeds.   If I click on the link (provided sometimes) and download a copy of “admin_console_init_webstart.jnlp” and double-click on it, it says:

Application Error:  Unable to launch application (see details in attachment below)

At one point, (I don’t know why)  it seemed to progress past this point, it loaded a white console with black text. But it doesn’t look at all like the “deployment wizard” I see in the “getting started” PDF.
I tried installing “FMP9” as well but it made no difference.
_______
So my most urgent questions are:
(1) how to get the DEPLOYMENT wizard to open, and
(2) if necc, how to get the “admin console” to open consistently (although I don’t know what its for)
(3) Seeing as I can’t even get the software to run — will I ever be able to set up the server to serve the eight or so databases they need? Does this require an expert in FMS?
attach.rtf
dgrrrAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will LovingPresident, Dedication Technologies, Inc.Commented:
Filemaker Server 9 is simply not compatible with Yosemite. FMS in versions prior to version 13 is also highly dependent on the version of Java installed to run the Admin Console and Deployment Wizard. It's unlikely that even if you were to get it Deployed that it could be trusted to run properly. The only way to have a reliable install of FMS on Yosemite is to use FMS 13 or the son to be released version 14.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dgrrrAuthor Commented:
I see. So the existing FileMaker Pro 9 workstations would need to be upgraded as well, right?
0
dgrrrAuthor Commented:
I  noticed that there's one other Yosemite computer that's running fine as a FMP9 client.

I work for a small non profit that just spent a ton on the new Imac, but can't afford to upgrade to FMS/FMP 13. So we're looking for any kind of work-around.
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

Will LovingPresident, Dedication Technologies, Inc.Commented:
Filemaker Pro is generally much more flexible around what operating system version it will run under, so Filemaker Pro 9 might install and appear to run fine under Yosemite.. However, Filemaker Server is much more restricted in terms of the OS version. If you can run End on a machine with an OS that it's officially qualified for then maybe you can put Pro on the other machines with Yosemite. Also as a non-profit you should be buying your FM licences through techsoup.org to save money
0
dgrrrAuthor Commented:
Thanks, I'll ask where they're buying the licenses.

Just to be clear - Will FMP9 workstations (clients) work with an FMS13 server? (I'd guess not.)
0
Will LovingPresident, Dedication Technologies, Inc.Commented:
There is a file format change between version 11 and 12. FM 7-11 are .fp7. FM 12+ is .fmp12 and they are not cross compatible.
0
Will LovingPresident, Dedication Technologies, Inc.Commented:
In comment ID: 40707231 there is a typo in the middle; the work "End" should be "FMS". If should say, "If you can run FMS on a machine with an OS that it is officially qualified for..."
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FileMaker Pro

From novice to tech pro — start learning today.