Cisco 1941Need help getting to Internet

Trying to configure new Cisco 1941 for basic Internet access.  From laptop on LAN I can ping the iSP gateway address but no other Internet IP addresses.  Any suggestions would be appreciated.  Here is the config:
LabRouter#sho run
Building configuration...

Current configuration : 1113 bytes
!
! Last configuration change at 16:34:03 UTC Sat Apr 4 2015
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LabRouter
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$UraZ$AXCkFRrLOJuZZDSJMY/ri0
!
no aaa new-model
!
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9 sn FTX183584QA
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 10.10.10.1 255.0.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 50.255.XXX.XXX 255.255.255.248
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 50.255.XXX.XXX
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password XXXXXXXX
 login
 transport input all
!
scheduler allocate 20000 1000
!
end

LabRouter#
Barry BrownCIOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Daniel SheppardNetwork Administrator/Engineer/ArchitectCommented:
With a 10.x.x.x address, you will need nat:




ip access-list extended RMAP-NAT
  permit ip 10.0.0.0 0.255.255.255 any
  deny ip any any

route-map RMAP-NAT
 match ip address RMAP-NAT

ip nat inside source route-map RMAP interface GigabitEthernet0/1 overload

interface GigabitEthernet0/1
 ip nat outside

GigabitEthernet0/0
 ip nat inside

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Barry BrownCIOAuthor Commented:
That was it.  Thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.