DVD Share Samba Ubuntu 14

G'day guys,

I'm trying to share my DVD-ROM with Samba.
Basically my system is Ubuntu (Kodibuntu or previously known as XBMCBuntu) and the way it must automount the DVD is weird to me.

If I place a DVD or CD in the drive it will inspect it and make a mount point in the folder /media/ and name it whatever the title of the DVD/CD is.

Now this sounds fantastic for local content manipulation or even seeing it like you would in windows. But my issue is that when I got to share this DVD-ROM with my network (need to install things on my Ultrabook) I have to manually set my location to the new folder based on the new title of the DVD.

Hopefully that makes sense. Here is an example.

I'm trying to install a game called "The Settlers 7". The normal way I used to share DVD-ROM was to mount it always to a folder location like /media/DVD and enter the code into /etc/fstab.

But there is no entry in /etc/fstab for my DVD-ROM, however it still automounts, but instead it shows up "/media/The Settlers 7".

So my real question is ; How do I mount a changing mounting location for network sharing?
Steven SwartsOwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Share the whole /media folder, and anything that gets mounted will show up there. On the Windows PC then just connect to /media and drill down to the mounted folder.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steven SwartsOwnerAuthor Commented:
Thanks for the suggestion. I will try that now and post back
0
Steven SwartsOwnerAuthor Commented:
Ok that does work for USB mounting I see.

But for DVD's or CD's I can't add a sub directory on my windows laptop as a mapped network drive.

It will work for the share Media, but not for "Media/The Settlers 7"

Also on a side note, I'm trying to install this game but it keeps saying "You do not have permission to access \\htpc\MEDIA\The Settlers 7\setup.exe. Contact your network administrator to request access."

It has to be either a Samba permission or a Unix permission issue. But so far I cannot see why its a Samba issue, because all the other shares work fine.

If its a Unix permission it is mounted as read only being a DVD and given ownership to the user "xbmc" being my default user. But if I look at the files and folders listed below the mount "The Settlers 7" it shows on a 'ls -al' that these are my permissions =
-rw-rw-rw- 1 xbmc xbmc     378168 Feb 26  2010 setup.exe

Open in new window

0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

rindiCommented:
With games it is often necessary to use a local CD/DVD drive in order to be able to install or even run them. They often will not run via network shares, as those shares aren't CD's or DVD's to the OS you want to install or run them on. This is part of copy protection schemes. Normal software CD's/DVD's usually don't have that issue.
0
Steven SwartsOwnerAuthor Commented:
Interesting. I originally thought the same. However I used my other windows laptop and put the DVD in there. Then I shared that DVD with the network.

Back on my Ultrabook I mapped the shared DVD. Started the setup.exe and the whole game installed fine.

I did notice that instead of a normal mapped network drive it had the acronym CDFS underneath the name. I'm guessing that in this way it by passes the copy protection by first decoding it on the host computer??

Can Linux not do the same?
0
rindiCommented:
I don't know. Maybe you can try using the "subst" command in Windows to assign another drive letter directly to the root of the mounted path you have now, something like:

subst g: "m:\The Settlers 7"

and then try running setup from G:
0
Steven SwartsOwnerAuthor Commented:
Hmm still got a permission error
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Can you try setting the x bits as well where you've shared the DVD?  You now have rw-rw-rw- try rwxrwxrwx instead. chmod 777 should do the trick.
0
David Johnson, CD, MVPOwnerCommented:
can you not mount cda and then share cd0 the same way as you could mount hda ? The permissions error seems to be that you can read but not execute but that should only be applicable to the host o/s
0
Steven SwartsOwnerAuthor Commented:
G'day Gerwin Jansen,

I can't change the permissions because it is a DVD and it errors with "system mounted as read only"

David Johnson,

I don't have any code in fstab or the like to automount the DVD. Ubuntu must have that else where to auto mount when a new DVD/CD is inserted. I also don't know how to mount it is a cda?? All I normally did was in terminal type

mount /dev/sr0 /media/dvd

Open in new window


and it would say "mount as a read only blah blah".

This is what I get if I check using the command

mount

Open in new window


/dev/sr0 on /media/The Settlers 7 type iso9660 (ro,nosuid,nodev,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)
0
Gerwin Jansen, EE MVETopic Advisor Commented:
I mean changing the security on the mount folder, it now has w bits which also make no sense as a DVD is read-only.
0
Steven SwartsOwnerAuthor Commented:
Yes that is what I thought you meant so I did that previously as well.
Here are the excerpts from the following command:

xbmc@HTPC:/$ ls -al

Open in new window


drwxrwxrwx   3 root root  4096 Apr  6 20:13 media

if I do the same command while in the sub folder /media I get this:

dr-x------  1 xbmc xbmc 4096 Feb 27  2010 The Settlers 7/

This I cannot change even if I try to. Also if I unmount the folder /media/The Settlers 7/ and try to mount it to just /media (this folder has full access for everyone) it still has the permission error.

Could it be an issue with the DRM? Or something similar? Here is my samba config:

http://paste.ubuntu.com/10749701/
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Settlers 7 is available on Steam as well, you may be able to activate in on Steam with your CD key - https://support.steampowered.com/kb_article.php?ref=5414-TFBN-1352 - you could contact Steam and explain that you don't have a CD/DVD drive with your ultrabook
0
Steven SwartsOwnerAuthor Commented:
Yeah well I CAN install it via my Windows computer sharing the DVD-ROM but why can't Linux do the same??

I appreciate the work around, but that is not my goal.
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Why is an easy question ;)  Difficult to answer in this specific case. Best guess is the copy protection on the disc, only working on Windows. Mentioned on the disc as compatible with Windows only. Don't know the specific copy protection scheme for S7 but you could find this online yourself if you really want to know this.

You could so try the same with a non copy protected game disc and see whether that works.
0
Steven SwartsOwnerAuthor Commented:
Valid point.

Must be copy protection issue.

Thank you all who helped.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.