Help to fix mailbox transfer queue and/or HTTP 500 Error in EMS,ECP & OWA

Would be hugely greatful for some help.  Situation is as follows:
I have an older small server which is a DC and running Exchange 2013.  It was beginning to struggle and a second more powerful platform has been bought.  It again is installed as a DC as I intend to remove the older server.  
Exchange 2013 is installed on the new server.  Mailboxes have been transferred.  Connectors have been edited, and mail works as intended with  the older server turned off.
I went to remove Exchange 2013 from the old server to find that the arbitration mailbox was still on the old server.  I queued the transfer and it is still 'Queued' 24 hours later.
I connected to the old server and was dismayed to find I was receiving HTTP 500 errors on the Exchange Management Shell (EMS) and on trying to connect to both OWA or ECP on the old Server.  (I can still seem to manage both servers from ECP & EMS on the new server.)
I am not sure if the HTTP issue is part of the fact that I cannot transfer the last arbitration mailbox, and if I could complete the transfer I would be able to unistall the old server and would not have to resolve the HTTP issue.  Can anyone offer some additional advice on either:
- Resolving the HTTP 500 error
or
- Fixing the transfer of the arbitration mailbox
With thanks

STEPS to resolve the HHTP issues tried so far  Note: Old Server is SVR1 (local), SERVER1 (fqdn)

Remove & Recreate OWA & ECP Virtual Directories
Remove-EcpVirtualDirectory -identity "SVR1\ecp (Exchange Back End)"
Remove-EcpVirtualDirectory -Identity "SVR1\ecp (Default Web Site)"

New-EcpVirtualDirectory -WebSiteName "Exchange Back End" -externalurl "https://SERVER1/ecp" -InternalUrl https://SVR1/ecp -Server SVR1
New-EcpVirtualDirectory -externalurl "https://SERVER1/ecp" -internalurl "https://SVR1/ecp" -Server "SVR1"

Remove-OwaVirtualDirectory -identity "SVR1\owa (Exchange Back End)"
Remove-OwaVirtualDirectory -identity "SVR1\owa (Default Web Site)"

New-OwaVirtualDirectory -WebSiteName "Exchange Back End" -externalurl "https://SERVER1/owa" -InternalUrl https://SVR1/owa -Server SVR1
New-OwaVirtualDirectory -externalurl "https://SERVER1/owa" -internalurl "https://SVR1/owa" -Server "POGSVR1.POGNET.local"

Open in new window

# Remove and replace Powershell
Get-PowerShellVirtualDirectory -Server SVR1 | Remove-PowerShellVirtualDirectory
New-PowerShellVirtualDirectory -Server SVR1 -Name PowerShell
Get-PowerShellVirtualDirectory -Server SVR1 | Set-PowerShellVirtualDirectory -BasicAuthentication:$false
IISReset

Open in new window

#Check and install WINRM
Get-WindowsFeature *IIS* #to check if it is installed
Add-WindowsFeature Winrm-IIS-Ext # to install

Open in new window

pogusAsked:
Who is Participating?
 
pogusAuthor Commented:
I have managed to resolve this problem as follows:
I cleared the move request on the arbitration mailbox (Useful option in cmdlets is format-list which gives detail which is not truncated and together with piping the output to a text file made trouble shooting much easier.

I found the instruction:
$AM = Get-Mailbox "SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}@POGNET.local" -Arbitration
$AMDN = $AM.DistinguishedName
Get-Recipient -RecipientPreviewFilter {ArbitrationMailbox -eq $AMDN}

Open in new window

to identify which mailboxes were using the arbitration mailbox, and was successfully able to move these to the new server.  
Set-Mailbox "UserID" -ArbitrationMailbox "SystemMailbox{1f05a927-d226-49cf-ab11-b8f7bf6d13aa}@domain.local"

Open in new window

After this it was possible to disable the Arbitration mailbox and uninstall Exchange
0
 
pogusAuthor Commented:
Solved it myself!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.