FTP Between Host and VMWare Client

I have a laptop running Windows 7 and have VMWARE Workstation 11 on it. One of my VMs is running Windows 2003 Server. I've configured my host system to run an FTP server using IIS - I followed the instructions in the attached document to do that. Everything appears to be working well up to the point of trying to connect to the server with an FTP client (filezilla) within the guest OS. At that point, it can't make the connection to the FTP site. The VMWARE guest has a single NAT Network Adapter installed. The instructions indicate that I need to provide the FTP client with the IP address of the host when connecting. This is where it fails.

Any ideas?
How-to-Setup-an-FTP-Server-in-Windows-us
cbridgmanAsked:
Who is Participating?
 
JohnBusiness Consultant (Owner)Commented:
Who owns this:
Ethernet adapter Local Area Connection 9:

    Connection-specific DNS Suffix  . : ad.holston-aap.com
    IPv4 Address. . . . . . . . . . . : 192.168.101.77

And who owns this:
Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . : attlocal.net
    Link-local IPv6 Address . . . . . : fe80::1a7:bfab:7f85:fde8%13
    IPv4 Address. . . . . . . . . . . : 192.168.0.101

Two Ethernet local adapters on two different subnets, neither of which are from the VMware NAT setup (  IPv4 Address. . . . . . . . . . . : 192.168.187.1)
0
 
JohnBusiness Consultant (Owner)Commented:
Change the Network Adapter for the VM to Bridged. Shut down the guest, then in Edit VM settings, Network, change the type to Bridged. Start the guest back up and try FTP again.

NAT puts your guest on a different subnet and makes VMware the DHCP server. Bridged is easier and more practical, especially for servers.
0
 
cbridgmanAuthor Commented:
I will give that a try and let you know.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
cbridgmanAuthor Commented:
Before I do set up a bridged connection, two questions:

should I delete the NAT connection?
should I choose replicate physical network connection state with the bridged connection?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You do not delete the network interface, or NAT connection, you just change it to Bridged Networking.

You can use a NAT network connection, but you need to configure Advanced NAT to pass the FTP traffic.

should I choose replicate physical network connection state with the bridged connection?

You may need to experiment with this ON and OFF, depending upon your Host network interface.
0
 
JohnBusiness Consultant (Owner)Commented:
As my friend Andrew said, no need to delete NAT, just change to Bridged. Bridged networking will work just like real server connections on the same subnet.

Watch what device is handing out DHCP. You may need to disable DHCP on the Server guest.
0
 
cbridgmanAuthor Commented:
I'm pretty much a rank beginner at this networking stuff. How would I disable DHCP?
0
 
JohnBusiness Consultant (Owner)Commented:
Start the Server, Admin Tools, DHCP and there should be an option to administer / disable DHCP. The reason is that your external router is probably providing DHCP and you do not want two DHCP servers on the same subnet.
0
 
cbridgmanAuthor Commented:
In the guest machine, there does not appear to be an option in Control Panel --> Admin Tools for DHCP. Is there some other way to get to that?
0
 
JohnBusiness Consultant (Owner)Commented:
You can go to Services (Part of Admin Tools) and stop DHCP Services. That should disable DHCP. Servers are mean to provide DHCP, so be sure you can retrace your steps later.
0
 
cbridgmanAuthor Commented:
I stopped the DHCP Client service, started up FileZilla, tried but failed again to connect to FTP. In the host OS, if I start FileZilla and connect as user anonymous to the localhost, it works. In the guest os, if I connect as anonymous to ip address 192.168.101.77 (that's the IP address of the host according to IPCONFIG), FileZilla throws the following error:

Status:      Connecting to 192.168.101.77:21...
Status:      Connection attempt failed with "EHOSTUNREACH - No route to host".
Error:      Could not connect to server

Any other ideas?
0
 
JohnBusiness Consultant (Owner)Commented:
if I start FileZilla and connect as user anonymous to the localhost, it works.

Check if FTP is set for Active and needs to be Passive.

http://slacksite.com/other/ftp.html
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you have now configured VM as Bridged ?

What IP Address does the VM get, and is it on the same LAN, as your Host ?

What are the IP Addresses of the Host and VM ?
0
 
cbridgmanAuthor Commented:
I was just looking at that. Following are the results of IPCONFIG from each

From the Host OS
--------------------------

Ethernet adapter Local Area Connection 9:

   Connection-specific DNS Suffix  . : ad.holston-aap.com
   IPv4 Address. . . . . . . . . . . : 192.168.101.77
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter Bluetooth Network Connection 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Local Area Connection 4:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : fd22:1c29:36b9:7632:bfe5:ccfc:94e1:cfc9
   Link-local IPv6 Address . . . . . : fe80::c0db:e20d:8ca5:6f71%40
   Autoconfiguration IPv4 Address. . : 169.254.111.113
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : attlocal.net
   Link-local IPv6 Address . . . . . : fe80::1a7:bfab:7f85:fde8%13
   IPv4 Address. . . . . . . . . . . : 192.168.0.101
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::e852:7e64:180b:dca3%48
   IPv4 Address. . . . . . . . . . . : 192.168.197.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::79d8:17d0:a705:a765%49
   IPv4 Address. . . . . . . . . . . : 192.168.187.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Tunnel adapter isatap.attlocal.net:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{B3D36643-9490-46D0-BCC7-8BE7A05F216D}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter 6TO4 Adapter:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Local Area Connection* 40:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{D2F01F71-4541-481A-83CC-67550E757283}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.ad.holston-aap.com:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : ad.holston-aap.com

Tunnel adapter isatap.{ECC76252-77D1-41CE-8DFF-A678373549F6}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{2AF97740-C581-4401-8098-0F06A456934D}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

From the VM Guest
----------------------------

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . : attlocal.net
   IP Address. . . . . . . . . . . . : 192.168.0.121
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
0
 
cbridgmanAuthor Commented:
And yes, it is now configured as Bridge
0
 
cbridgmanAuthor Commented:
With regard to passive vs. active FTP, is that something that gets set on Windows Firewall on the host? At first, I enabled only FTP Server (FTP Traffic In) and FTP Server (FTP Traffic Out).

I've now enabled FTP Server Passive (FTP Server Passive - Traffic In).

Still no help
0
 
cbridgmanAuthor Commented:
Who owns this:
Ethernet adapter Local Area Connection 9:

This is from VPN - I've now shut that down

    Connection-specific DNS Suffix  . : ad.holston-aap.com
    IPv4 Address. . . . . . . . . . . : 192.168.101.77

And who owns this:
Ethernet adapter Local Area Connection:

This is me. ATT (UVERSE) is my internet provider)

    Connection-specific DNS Suffix  . : attlocal.net
    Link-local IPv6 Address . . . . . : fe80::1a7:bfab:7f85:fde8%13
    IPv4 Address. . . . . . . . . . . : 192.168.0.101

Two Ethernet local adapters on two different subnets, neither of which are from the VMware NAT setup (  IPv4 Address. . . . . . . . . . . : 192.168.187.1)
0
 
JohnBusiness Consultant (Owner)Commented:
OK but back further you say  "Status:      Connecting to 192.168.101.77:21..."   .101 is the disconnected VPN device.   This may be part of your addressing problem.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
That's the issue, two different networks in use here....

192.168.101.77 is not going to reach : 192.168.187.1

Are you sure your VM is in Bridged ?

Do you use DHCP Server on your network ?

where does your Host get it's IP Address from ?
0
 
cbridgmanAuthor Commented:
The VPN connection was the culprit. After shutting it down, I was able to FTP in.

Thanks for your help
0
 
cbridgmanAuthor Commented:
oops, sorry john, i meant to award the points to you. Can I undo that?
0
 
JohnBusiness Consultant (Owner)Commented:
I pointed the VPN issue out earlier so why only one solution accepted?
0
 
JohnBusiness Consultant (Owner)Commented:
@cbridgman  - Thanks for the update and for following up. I am glad we were able to help you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.