FTP Access to Synology NAS which is connected to Sonicwall NSA 220W, How to Setup?

I am trying to get FTP access setup to a central NAS drive on our network.  I had this working before but the network hardware was changed, specifically the router.  Currently we have Comcast Cable Modem internet service coming in to a Sonicwall NSA 200W router.  Our central storage drive NAS device is a Synology DS213+ and is connected to a LAN port on  the Sonicwall router.  In the past when FTP was working with the NAS drive, I had opened up port 21 on the Comcast modem and enabled FTP on the Synology DS213+ NAS and it worked.  The same setup is not working now and everytime I try to connect via FTP, it gives me an error message that it failed to connect to the host.  Here are the specifics of what I have done:
1.  Created a NAT Policy for FTP using our WAN Interface IP to our FTP Server.
2.  Created an address object for our FTP Server using the local IP address of our NAS drive.
3.  Created a Firewall access rule from WLAN  to LAN for FTP.
I created these things all on the Sonicwall NSA 220W but to my dismay, I still receive the failed to connect to host message.
I am using an FTP utility that asks for the Server Name, Host Name/IP Address, Path, Port, User name and password.

Can somebody please help me understand what I am doing wrong and guide me with the details of how to correctly set this up?

Thanks!
mjchevalierAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Trenton KnewOwner / Computer WhispererCommented:
are you watching the system log on the sonicwall to confirm that the packets are being dropped at the firewall?  At least make sure the sonicwall is the problem first.  it should tell you if the packet is dropped.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mjchevalierAuthor Commented:
Thanks Trenton, I will try to check on that and will post back.
0
David Johnson, CD, MVPOwnerCommented:
on the sonicwall you have to enable port forwarding of port 21/ftp to the synology ip address
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mjchevalierAuthor Commented:
Thank you David Johnson.  I thought that I did that but I am not sure if what I did is correct  I added a NAT policy with an original destination of WAN Interface IP with a Translated Destination of FTP Server.  I created an address object for FTP Server with the internal IP address of the Synology NAS.  After that, I added a Firewall access rule for Wan to Lan using FTP service with a destination of the WAN Interface IP.  I can give you all the details if you need them.  Does this sound correct to you?
0
David Johnson, CD, MVPOwnerCommented:
I'm not familiar with that router but it seems ok
0
Trenton KnewOwner / Computer WhispererCommented:
did you monitor the log to see if the FTP traffic was being dropped?
0
mjchevalierAuthor Commented:
Trenton, I immediately attempted to monitor the log but the Sonicwall just sits and spins a 'Processing' icon but never shows me the log. There are 2 ways I can get to the log but both hang on this Processing window?  I contacted Sonicwall to get help but they have not been able to resolve it yet. Makes me wonder if there is something wrong with the box? Thank you for following up. I will follow up as soon as I get to the log monitor and check it out. Thanks
0
Trenton KnewOwner / Computer WhispererCommented:
You're getting a hang up when you click log/view?
sonicwall menu
I wonder if you need a firmware update
0
mjchevalierAuthor Commented:
Trenton, I am getting a spinning 'processing wheel' when I first click on Log.  The log entries can be seen greyed out in the background but I cannot click on them and the 'processing wheel' never goes away.  Very frustrating.  I will check to see if I am missing an updated firmware.  Thanks for the suggestion.
0
mjchevalierAuthor Commented:
I just updated the firmware to current version.  Unfortunately there is no change when trying to view the log files.  As soon as I click on Log Monitor, a dialog box appears in the middle of the screen that says Processing, please wait.  It never stops processing and I cannot look at any of the log entries.  I have a call into Sonicwall to help with this.  I will report back when I have more news.  Thank you.
0
mjchevalierAuthor Commented:
I had the wrong external IP listed in my NAT Policy for the FTP service.  Found this through the logs, changed it and voila, it worked as expected.  Thank you for your help!
0
Trenton KnewOwner / Computer WhispererCommented:
glad you got it sorted.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.