Cisco switch and Voice VLAN, QOS

I have a Cisco switch connected to a Cisco router in stick mode with VLAN1 for data and VLAN100 for voice.  The computers will be on VLAN 1 and the Avaya Phones will be tagged on VLAN 100.  The phone will plug into port 1 and configured to tag 100 and the computer will then plug into the phone.  Is the following configuration correct if I were wanting to configure port1 and prioritize the Avaya phone?  

vlan 100
name Avaya_Voice

interface vlan 100
ip address 10.1.1.2 255.255.255.0
ip route 10.0.1.1.1

interface Ethernet 0/1
mls qos trust cos
switchport nonegotiate

switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,100
priority-queue out
spanning-tree portfast trunk

Thanks!
tyty4u2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

harbor235Commented:
You should never use portfast on switch interconnects and I would not use vlan 1 to assign to host ports and/or native vlans assignments on trunks. i would create a native vlan, e.g. 899 for native vlan trunk purposes. What Cisco switch model are you using? E0/1 (10baseT port), must be pretty old?

You can use access mode to a tandem config when the port is defined as follows:

Try this :

interface E0/1
switchport access vlan 10   **** new non-vlan 1 data vlan
switchport mode access
switchport access vlan voice 100

The other problem you have is that Avaya does not support cdp but you could use lldp but since you may have an old switch i am not sure its supported. Switch model and IOS version?

harbor235 ;}

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eeRootCommented:
Trunked ports are used for interconnecting network devices (switches, routers, etc).  An access port that is shared by a phone and PC would look like this.

switchport mode access
switchport access vlan 1
switchport access vlan voice 100
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.